Results 1 to 3 of 3
  1. #1

    help with 87 650sx

    Completely stock except for a new inline electric fuel pump when I bought it a few weeks ago. I've blocked off the oil injection, added a flush kit, and took the center bar out of the intake grate. It also has new rings, and base gasket. The pistons look great, cylinders are great, all the other gaskets look good. Hittin 125 on both cylinders. I'm wanting to keep this thing stock for the most part until at least the end of summer...at that point I will either sell it or start doing bolt ons
    I need a little help with it, I'm getting gas to the carb, but not through it. With the fuel pump on I can stick a toothpick in the front of the carb and hit the float valve and then the fuel gushes wonderfully. I'm wondering with the new pump if there's some mis-routing, which I'm pretty new and have done what I can with it and read on here about all I can. There's no hoses coming from the fuel selector switch. The reserve line is used as the primary, runs to the fuel pump and from there to the inlet on the carb. Return line comes off the carb and back to the gas tank. The pulse line is running to nothing, there's an unused inlet on the gas tank, and there is nothing coming off of the water separator. I took some pics to give you guys a general idea of what I'm working with and I completely disconnected all the lines and am ready to start fresh...or if somebody has either a working stock fuel pump or a reasonably priced carb with built in pump like a 38 or 44 I would consider going that route also.
    -ok I know in the center picture all the in/outlets on the gas tank are used....but I seriously had no idea where the pulse line went and when I snapped the pic thats where I had it...I'm really new to these and really new to wrenching period and the 88 650 I bought last year was a breeze compared to this
    -Yeah I did a little more digging, looks like the pulse line hooks up to the stock fuel pump...which this stupid pump doesn't have a place to run the pulse line in YAH!!! I also just missed the only stock pump on ebay for $25...so far I have $500 in a ski that won't start, not good!!! I'm really close with it, find a pump or a carb and I'm puttin in new fuel lines...these are pretty brittle, and hopefully I'm set.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	050100_1527[00].jpg 
Views:	101 
Size:	65.5 KB 
ID:	186001   Click image for larger version. 

Name:	050100_1528[00].jpg 
Views:	97 
Size:	81.1 KB 
ID:	186002   Click image for larger version. 

Name:	050100_1528[01].jpg 
Views:	118 
Size:	88.3 KB 
ID:	186003  
    Last edited by swccrunner; 05-01-2010 at 06:46 PM. Reason: adding info


  2. #2
    Found a used fuel pump on ebay, the ski ran today on the garden hose for a little bit. My next issue is restarting, I disconnected the hose and blew all the water out of the exhaust...and now I cant seem to get it started up again. I changed out the plugs thinking I may have fouled the others and nothing...any ideas?

  3. #3
    Quote Originally Posted by swccrunner View Post
    Found a used fuel pump on ebay, the ski ran today on the garden hose for a little bit. My next issue is restarting, I disconnected the hose and blew all the water out of the exhaust...and now I cant seem to get it started up again. I changed out the plugs thinking I may have fouled the others and nothing...any ideas?

    Did you get water in the engine?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. I need help with a 1989 650sx.
    By ccassone in forum Kawasaki Open Discussion
    Replies: 6
    Last Post: 01-05-2007, 10:01 AM
  2. Need help with pump issue
    By Flyer in forum 4-Tec Performance
    Replies: 17
    Last Post: 05-23-2006, 05:40 PM
  3. Help with stock prop and RXT stage 2
    By Kinchyle in forum 4-Tec Performance
    Replies: 13
    Last Post: 04-18-2006, 08:36 AM
  4. Need help with 04 S.C. rebuild
    By Turbo Todd in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 04-10-2006, 08:03 PM
  5. Help with Riva air filter kit
    By 818RXP in forum 4-Tec Performance
    Replies: 20
    Last Post: 08-19-2005, 06:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •