Results 1 to 10 of 10

Thread: Question

  1. #1
    2008 RXT outonalimb's Avatar
    Join Date
    Jun 2009
    Location
    Ct and NH
    Posts
    162

    Question

    Like so many other people today took out the ski, it ran great then about 30 min in I got a bad vibration. I let off, any time i go over 10 mph, around 4000 rpm's, it vibrates pretty bad. I ck'ed the intake no weeds or sticks. I was at Candlwood lake. The ski has 59 hrs... No water in hull. I just replaced the prop and in stalled a ss ring. I will be taking the pump back off to ck everything I did but, could it be somthing else? Thanks for your help...


  2. #2
    2008 RXT outonalimb's Avatar
    Join Date
    Jun 2009
    Location
    Ct and NH
    Posts
    162
    Well I just pulled the pump off with the help of my son, looked inside and there it is a stick about the size of a pencil, jammed in... Cleaned it up and she is ready to go... Boy I am glad I have the SS wear ring or that thing would of done some damage....

  3. #3
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Funny how the littlest of things can cause such a situation..Glad you found your problem..

  4. #4
    2008 RXT outonalimb's Avatar
    Join Date
    Jun 2009
    Location
    Ct and NH
    Posts
    162
    Thanks Snoman, when I saw it it did surprise me. SURPRISE!!!!! A $10,000 machine, OOS, by a stick......

  5. #5
    Faster Than a Snail on a Log mongorunner's Avatar
    Join Date
    Jun 2007
    Location
    North of Amarillo TX
    Posts
    741
    Quote Originally Posted by H2oinmyveins View Post
    Thanks Snoman, when I saw it it did surprise me. SURPRISE!!!!! A $10,000 machine, OOS, by a stick......

    happens more often than you think, good thing you're willing to turn wrenches on your own, most people would have taken it to the dealer and charged an arm and a leg for a pencil stick

  6. #6

    Join Date
    Apr 2008
    Location
    Plainfield, IL
    Posts
    1,237
    +1
    10
    When I get a stick when Im riding while Im moving I shut the ski off. The start it and go like reverse. And then usually jam the gas a second and it will shred the stick. Happens some times.

  7. #7
    2008 RXT outonalimb's Avatar
    Join Date
    Jun 2009
    Location
    Ct and NH
    Posts
    162
    Speed, after seeing and knowing the result of the stick jammed in the prop, I can see going in reverse might help... If anyone has had a newer SKI DOO snowmobile, they have a electronic reverse. This shuts the engine off and restarts in reverse rotation. To resume forward hit the button and the engine shuts off and starts in normal rotation. This feature would be nice to free up jammed props... This should also be covered and gone over with every new PWC owner...

  8. #8
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Quote Originally Posted by Speed_Freak_039A View Post
    When I get a stick I shit the ski off.
    Shit the ski off????

  9. #9
    suck my wake's Avatar
    Join Date
    Apr 2006
    Location
    Sugar Grove IL
    Posts
    2,872
    +1
    12
    Quote Originally Posted by Snoman View Post
    Shit the ski off????
    Yea no shit ma!!!! What the hell is that

  10. #10

    Join Date
    Apr 2008
    Location
    Plainfield, IL
    Posts
    1,237
    +1
    10
    Quote Originally Posted by Snoman View Post
    Shit the ski off????
    LMAO. Sorry guys. The u and i button are right next to each other.I fixed it.


    Usually like rock the ski around or go in reverse and shut it off while its moving. Just play with it it will come out.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXT handling question
    By MPower in forum 4-Tec Performance
    Replies: 5
    Last Post: 08-11-2009, 10:04 AM
  2. 158 Thermostat question...
    By rx4pain in forum 4-Tec Performance
    Replies: 34
    Last Post: 11-21-2008, 10:36 PM
  3. Oil Level question , this thing mixes me up :(
    By rxp_boy in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-23-2005, 10:03 AM
  4. Question for the Hulk
    By Therock in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-20-2005, 07:13 AM
  5. RXP VTS Question
    By 1FastTrespiper in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-08-2005, 10:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •