Results 1 to 3 of 3

Thread: limp mode!

  1. #1
    german06's Avatar
    Join Date
    Dec 2009
    Location
    Fortlauderdale
    Posts
    69

    limp mode!

    some body can help me , my jet ski get 30mph and hit the limp mode, I jus fix the wastegate, was stock i don't think it's over boost because hit the limp mode at low speed. I don't know what happen with this jet ski when it's on the trailer runs perfect 6500 rpm.


  2. #2
    Quote Originally Posted by german06 View Post
    some body can help me , my jet ski get 30mph and hit the limp mode, I jus fix the wastegate, was stock i don't think it's over boost because hit the limp mode at low speed. I don't know what happen with this jet ski when it's on the trailer runs perfect 6500 rpm.
    mine is doing the same thing
    I talked to someone and they said if I
    put new plugs in it b4 I started it for the 1st time of the season
    (while all the winterizer junk was in the cylinders) that I fouled out the new plugs

    I'm going to test it with the old plugs 2maro.. if it works I'll let ya know..

  3. #3
    Quote Originally Posted by german06 View Post
    some body can help me , my jet ski get 30mph and hit the limp mode, I jus fix the wastegate, was stock i don't think it's over boost because hit the limp mode at low speed. I don't know what happen with this jet ski when it's on the trailer runs perfect 6500 rpm.
    You shouldn't rev the engine up so high out of the water. Your just asking for trouble imo. You run the risk of floating the valves and I think the manual comments about this also. 3500 is all you need on the hose. Brokeazz thinks it might be an oil sensor or something like that. Check your codes.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Limp mode on a 97 STS.
    By ccassone in forum 2-Stroke Performance
    Replies: 2
    Last Post: 08-29-2009, 07:43 AM
  2. limp mode solutions/ suggestions on 95 slx
    By slxcrazy in forum Polaris How To & FAQs
    Replies: 14
    Last Post: 05-06-2007, 10:39 PM
  3. gas level limp mode ?
    By Bone1050 in forum Polaris Open Discussion
    Replies: 11
    Last Post: 03-22-2007, 06:58 PM
  4. limp mode
    By tommy33mac in forum Polaris How To & FAQs
    Replies: 13
    Last Post: 03-21-2007, 09:23 PM
  5. limp mode vs over of fuel
    By andy95'slx780 in forum Polaris PWC Performance
    Replies: 1
    Last Post: 10-02-2006, 04:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •