Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 21
  1. #1

    97 SL 900 Stator access?

    Im just bought a super clean sl 900 for $100, and the guy said a mechanic told him the cdi went out. I've bought the update kit, and was wondering if anyone could give me advice on accessing the stator. Should I take it to a mechanic?


  2. #2
    casey67's Avatar
    Join Date
    Sep 2006
    Location
    Lemont,IL
    Posts
    2,571
    +1
    35
    Welcome to Green Hulk !
    The stator is not a very difficult job. Do you have much experience working with engines ?
    Might be better to double check the cause of your no-start.
    Check the battery voltage when cranking,needs to be atleast 10.6 v
    What is the part # on the CDI that is in your PWC ?

  3. #3
    The part # was 2873091. I saw a post mentioning moving the fuel tank over to access the stator. I have replaced starters, brakes, and carbs before, but not a super good mechanic.

  4. #4
    casey67's Avatar
    Join Date
    Sep 2006
    Location
    Lemont,IL
    Posts
    2,571
    +1
    35
    Quote Originally Posted by redfro View Post
    The part # was 2873091. I saw a post mentioning moving the fuel tank over to access the stator. I have replaced starters, brakes, and carbs before, but not a super good mechanic.
    That part # is the update kit .
    What is the # on the CDI that is currently in your craft ?
    Your CDI is in the electrical box above the battery.
    Do you have a "muli-meter" to check the cranking voltage ? A weak battery is the #1 reason for a no-spark condition on Polaris pwc.

  5. #5
    I forgot to write down the numbers, but it looked original and no cut black wire like someone mentioned is required for the update. I am disconneting the oil injection and replacing the fuel pump with mikuni before I run it. Really want to change stator and cdi to make it more dependable. I just got back from buying a battery to solve that problem.

  6. #6
    Do I remove the tank to access the stator? I bought a oil pump block off kit that
    I was going to install at the same time, and that whole area seems impossible to get to.

  7. #7
    ryandi2's Avatar
    Join Date
    Aug 2009
    Location
    conesus ny!
    Posts
    2,092
    +1
    19
    yes you need to remove the tank.. take the hood off.. take the oil tank out..and unbolt the gas tank its a pain in the butt to get out the first time..

    as casey said check for spark when you get the new battery hooked up.. take a picture of the cdi and post the part number as well..

  8. #8
    Here's a pic of the cdi. The guy I bought it from said he hooked the battery up backwards. I think I'm going to just update the stator, and save some headaches.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	cdipic.jpg 
Views:	106 
Size:	493.0 KB 
ID:	186389  

  9. #9
    casey67's Avatar
    Join Date
    Sep 2006
    Location
    Lemont,IL
    Posts
    2,571
    +1
    35
    Yes, that is the "old style ignition".
    These craft are getting so old,alot have had the newer parts installed already.

    Just curious.
    Did it start with the new battery?

    Oh, this is the Domestic engine, it does not need the Mikuni fuel pump.
    It has 2 fuel pumps mounted on the front/rear carbs.

  10. #10
    It did have spark. Does that mean that the cdi is good? Also, do those fuel pump parts come with the carb kits. I mention cause the owner mentioned some hesitation taking off, and then it would haul. It has a plug boot that came loose, and a grey fuel line that is disconnected. Once I figure those out, I will try to start it. Thanks for the help.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. POLARIS SL 900 stator problems
    By BADSL900 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 06-07-2011, 10:08 PM
  2. 96 sl 900 stator
    By Dvandy1 in forum Polaris Open Discussion
    Replies: 1
    Last Post: 07-01-2010, 10:27 AM
  3. sl 900 stator question
    By Flyerjack in forum Polaris How To & FAQs
    Replies: 6
    Last Post: 08-08-2008, 03:39 PM
  4. Wtb: 97 Sl 900 Hood
    By Tay71980 in forum Polaris Classifieds
    Replies: 3
    Last Post: 07-21-2008, 09:03 PM
  5. 97 SL 900 hard to start
    By S12L00X in forum Polaris Open Discussion
    Replies: 3
    Last Post: 05-15-2007, 06:28 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •