Results 1 to 8 of 8

Thread: turbo rxp help

  1. #1

    Join Date
    Apr 2009
    Location
    montreal canada
    Posts
    29
    +1
    1

    turbo rxp help



    I have an rxp 04 that i modified last year turbo.darton sleeve cp piston ,55 lbs inj,etc ...with 28lbs of turbo boost.. so far i put 84 hours on it with no major problem ...only this year!! the ski started to do do something weird ...i can not figured it out !! its simply when i go straight or when i go right turns the ski goes fine but when i do a left sharp turn the motor hesitate and backfires !!!! weird hein !!!??? ...i checked for any loose wire...i also change spark plugs ...i almost checked everything but can not find anything!!! ...i need some help please! thank you


  2. #2
    Gone in 3.0 seconds... RXPT400's Avatar
    Join Date
    Nov 2007
    Location
    USA
    Posts
    1,527
    sounds like a harness wiring problem touching ground somewhere and getting shorted only when you turn left. If I were you I will check all your engine harness connections and sensors. follow all your wires and see if they are routed properly not touching any hot exhaust pipes or moving parts. also check around your engine grounds on the engine block. check you engine mounts also ......

  3. #3

    Join Date
    Apr 2009
    Location
    montreal canada
    Posts
    29
    +1
    1
    thank you for replying...i checked all the wiring i even put a new engine harness!! somebody told me that it might be the strainer of the fuel pump that is faulty !!! i will check the fuel pump and test it again....

  4. #4

    Join Date
    Nov 2005
    Location
    North East Mo
    Posts
    306
    +1
    1
    did you check the wire harness that runs up through your steering stem as it might be trying to short out the kill switch?

  5. #5

    Join Date
    Apr 2009
    Location
    montreal canada
    Posts
    29
    +1
    1
    yes i did...i only have this problem when the gforce is more than 0.5g not when i steer to the left !!! the perfect example is the greenhulk picture!! leaning to the left at 50 or 60 mph...!! that's when it cuts!!

  6. #6
    race jase's Avatar
    Join Date
    Feb 2007
    Location
    auckland nz
    Posts
    539
    +1
    46
    Maybe you should up your fuel pressure just to count out that you are not running lean,
    is your fuel pump filter clean.

    Jase

  7. #7
    Gone in 3.0 seconds... RXPT400's Avatar
    Join Date
    Nov 2007
    Location
    USA
    Posts
    1,527
    you said you installed a turbo kit. what other engine mods was performed on this ski and who did it (a professional jet ski mechanic or someone else?..Im just trying to figure out if all the engine components were torque to specs such as the camshaft sensor, crankshaft sensor, flywheel bolts, stator etc...do you see where Im coming from??....

  8. #8

    Join Date
    Apr 2009
    Location
    montreal canada
    Posts
    29
    +1
    1
    my friend has an turbo rxt 06 with exactly the same setup as mine ...and he had the same problem!!! last year !! each time he did a long left turn at let say at 30deg. the engine would backfires and the gas pressure would drop to 20lbs....only at sharp left turn more than 5000rpm...two days later his ecu blew!!! he changed the wiring harness because the signal of the fuel pump pin, melted !!!...also he installed a relay on the fuel pump circuit so that the feed become a signal !! very smart!..changed ecu...fuel pump...and case closed. he never had this problem again ....in my case i dont loose the fuel pressure!! and i changed the whole wiring harness... wow im going nuts with this thing ...lol

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. need help on turbo rxp prop
    By El daddy in forum 4-Tec Performance
    Replies: 7
    Last Post: 05-15-2011, 09:07 PM
  2. Open loop setup for turbo rxp....pls help.....!!
    By syahrol444 in forum 4-Tec Performance
    Replies: 3
    Last Post: 08-20-2010, 04:31 PM
  3. rxp turbo needs help from canada
    By nabil325 in forum 4-Tec Performance
    Replies: 12
    Last Post: 05-17-2010, 06:03 AM
  4. Help a [turbo] RXP brother out with nozzle/prop rpm questions.
    By engineermike in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 02-24-2008, 02:30 AM
  5. rxp help from down under
    By fosters in forum 4-Tec Performance
    Replies: 17
    Last Post: 12-27-2005, 11:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •