Results 1 to 9 of 9
  1. #1
    Cliffy's Avatar
    Join Date
    Oct 2009
    Location
    UK,
    Posts
    566

    Idle Speed On Hose

    Just been flushing the ski out with some salt killer after use this weekend

    I noticed on the hose the ski idles at 3thou or just above that, is this normal??

    On the water she sits between 12-13

    Just a bit worried

    Thanks
    Neil


  2. #2
    ryandi2's Avatar
    Join Date
    Aug 2009
    Location
    conesus ny!
    Posts
    2,092
    +1
    19
    yeah cliffy its normal!

    there is no load on the engine that is why

  3. #3
    Cliffy's Avatar
    Join Date
    Oct 2009
    Location
    UK,
    Posts
    566
    Quote Originally Posted by ryandi2 View Post
    yeah cliffy its normal!

    there is no load on the engine that is why
    Cheers dude panic over I'll stop having kittens

  4. #4
    la90043's Avatar
    Join Date
    Oct 2006
    Location
    Los Angeles
    Posts
    1,201
    And also it should only be on the hose for no more than a few minutes. like 2 minutes. the bearings inside the water pump (jet) overheat and seize.

  5. #5
    ryandi2's Avatar
    Join Date
    Aug 2009
    Location
    conesus ny!
    Posts
    2,092
    +1
    19
    Quote Originally Posted by Cliffy View Post
    Cheers dude panic over I'll stop having kittens

    hahaha im the same way!

    ride hard worry less buddy!

  6. #6
    Cliffy's Avatar
    Join Date
    Oct 2009
    Location
    UK,
    Posts
    566
    Ride hard, my JetSki club membership number is 007, the name is Bond, James Bond lol

    Since ive got that number theres been no stopping me

  7. #7
    bowsniper's Avatar
    Join Date
    Aug 2008
    Location
    macomb,michigan
    Posts
    5,896
    +1
    6



    Go Cliffy Go! I see that rideplate works pretty good! lol

  8. #8
    Cliffy's Avatar
    Join Date
    Oct 2009
    Location
    UK,
    Posts
    566
    Quote Originally Posted by bowsniper View Post



    Go Cliffy Go! I see that rideplate works pretty good! lol

  9. #9
    bowsniper's Avatar
    Join Date
    Aug 2008
    Location
    macomb,michigan
    Posts
    5,896
    +1
    6
    Now ya need a jet trim bow shield and your all set!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. high idle on hose
    By ercBOOSTED in forum Yamaha PWC Performance (4-stroke)
    Replies: 5
    Last Post: 07-15-2013, 11:01 AM
  2. Idle speed on 1996 GTX 787?
    By CZSteve in forum 2-Stroke Performance
    Replies: 3
    Last Post: 07-01-2013, 12:14 PM
  3. How do you adjust idle speed on 750sl
    By flash-1295 in forum Polaris How To & FAQs
    Replies: 5
    Last Post: 07-10-2011, 11:05 AM
  4. Questions on hoses, water getting in rough idle.
    By USAFrider in forum Polaris Open Discussion
    Replies: 3
    Last Post: 05-27-2011, 01:15 PM
  5. 951 Idle speed on hose
    By kidafa in forum 2-Stroke Performance
    Replies: 21
    Last Post: 11-30-2009, 06:12 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •