Results 1 to 8 of 8
  1. #1

    95 XP 2k-5k bog!?

    Hey,

    We took our 95 and 97 XP's out this evening and did a pretty nice little 10 mile cruse with it. On the way back the 95 picked up a low throttle (1/4 to 1/2) throttle and 2000-5000 RPM bog. Above that it runs fine. Fuel filter still looks clean and just changed the plugs. It got better after a cool down but still seems to do it a little. Still has plenty of gas.

    Is there anything I should look for?


  2. #2
    Work Harder, Millions on Wellfare Depend On Us! ultramaxracing05's Avatar
    Join Date
    Aug 2009
    Location
    Beaumont, Texas
    Posts
    2,999
    +1
    123
    have you replaced the grey fuel lines?
    have you checked the internal filter inside the carb?
    how did your plugs look when you replaced them? chocolate,white, black, or wet?

  3. #3
    Nice color on the plugs. A nice chocoloate. The fuel lines have all been replaced last year and I just cleaned the carb filters about 2 weeks ago. This is only the second time we've had it out since cleaning the carbs.

    I just deleted the oil injection pump and am running a 40:1 ratio. I'm worried I might have overheated it as it didn't seem to do it as bad after we let it cool for a bit. Is there a good way to blow the sand and crap out of the coolant system?

  4. #4
    Work Harder, Millions on Wellfare Depend On Us! ultramaxracing05's Avatar
    Join Date
    Aug 2009
    Location
    Beaumont, Texas
    Posts
    2,999
    +1
    123
    first check if they are clogged, does that engine has a temp sensor? if so did it go off?
    my guess is that maybe one of the diapraghms inside the carb ripped.

    Me and my buddy were going to go riding this past weekend, and his ski had been sitting for a while with no gas on the carbs, they were dry, I inspected all the gaskets, and they were fine, but when we fired it up it ran like crap. took it apart and the diagprhams were shot.

    maybe someone with more knowledge might chime in, I strongly believe its a fuel delivery problem

  5. #5
    I believe it to be a fuel delivery problem also. I just think its strange that it would pop up after running it so much. The temp sensor never gave a warning but the engine felt hotter than I've ever noticed before. We where on a sandy beach and Im' hoping the coolant system didn't get clogged

  6. #6
    Work Harder, Millions on Wellfare Depend On Us! ultramaxracing05's Avatar
    Join Date
    Aug 2009
    Location
    Beaumont, Texas
    Posts
    2,999
    +1
    123
    indside the pump where the prop is there is a place where the pressure from the pump itself pumps water to your engine, its got like 4 or 5 little holes, make sure the are not clogged with debri

  7. #7
    Make sure ITEMS # 4, 6, AND #10 arn't clogged with sand.

    http://partsfinder.onlinemicrofiche....e=13&A=27&B=11

    It would take a helluva lot of sand to clog anything else with in that engine--the plumbing is fairly straight forward with minimal slow-flow zones with the exceptions of the aforementioned fittings.

    --DvD

  8. #8
    Sweet, Thanks guys I really appreciate it!

    I was doing some routine maintenance on them tonight and notice it only had about 1-maybe 3 inches of fuel in the tank! DUH. It may have just been running out of fuel, although that wouldn't make much sense since it would run real strong after the bog unless it had a hard time initially picking the fuel up. It seems like most of the time when they run out of gas they run fine on the bottom and bog on top.

    If that is it I'll feel pretty stupid. My 95 and 97 XP both have broken fuel gauges. I can see the fuel level easy in my 97 but my 95 is real tough to see the actual fuel level.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 95 XP 800 bogging
    By falcondrummer in forum 2-Stroke Performance
    Replies: 1
    Last Post: 05-16-2008, 02:28 PM
  2. 95 xp running bad
    By pappastratos in forum 2-Stroke Performance
    Replies: 5
    Last Post: 05-22-2007, 02:54 PM
  3. 95 xp question
    By Blackhardt in forum 2-Stroke Performance
    Replies: 4
    Last Post: 04-26-2007, 09:55 AM
  4. 95 xp fuel line clamps
    By Blackhardt in forum 2-Stroke Performance
    Replies: 3
    Last Post: 01-23-2007, 08:39 PM
  5. 95 xp pump and nozzle
    By Blackhardt in forum 2-Stroke Performance
    Replies: 10
    Last Post: 01-21-2007, 09:30 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •