Results 1 to 6 of 6
  1. #1

    coupler for 2000 slx

    Seeing if anyone has one. Thanks


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,575
    +1
    1,272
    That would be the rubber bonded coupler, I think.

    Same coupler was used on many models and years.

  3. #3

    coupler

    Yes I need one and would buy one from a guy in here. So hopefully some one has one. I think its causing the impeller to touch on the walls. I just replaced the whole driveline in my 1996 slx and would just rather replace the coupler. Alot Cheaper!!

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,575
    +1
    1,272
    Quote Originally Posted by ercoach View Post
    ... I think its causing the impeller to touch on the walls.

    I just replaced the whole driveline in my 1996 slx and would just rather replace the coupler.

    A lot Cheaper!!
    What do you mean by the 'whole' driveline?

    A bad coupler should not cause the impeller to rub in the jet pump wear ring.

    Did you remove the pump base that is sealed to the hull?

    The impeller is supposed to be held in place by the jet pump stator stub shaft.

    Did you check that the bearings in the pump stator are good before installing the jet pump?

    No corrosion between the pump sections?

    Is the pump properly assembled?

    Some history and details might be useful.

  5. #5

    Join Date
    May 2008
    Location
    St Paul, Mn
    Posts
    177
    I have the black coupler that you are looking for. Shoot me a PM if you still need it. K447, thanks for the info I could not figure out what that meant? That MFD I hope makes it there on time.

  6. #6
    Im sorry!! The splines to the shaft were damaged. I was just needing a coupler incase of another problem. Any suggestions to check if you hear a different noise from the pump area. It seeems like it may be rubbing a little on my 2000 slx. Thanks

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB thermostat and pop off for 2000 SLX
    By richsrq in forum Polaris Classifieds
    Replies: 6
    Last Post: 06-08-2012, 09:46 AM
  2. WTB WTB Pump Assy for 2000 SLX 1200
    By 00SLX in forum Polaris Classifieds
    Replies: 2
    Last Post: 05-04-2011, 08:15 AM
  3. WTB NEEDED - Drive shaft and coupler for Polaris SLX 785 PRO
    By koryk in forum Polaris Classifieds
    Replies: 2
    Last Post: 02-20-2011, 12:25 PM
  4. WTB WTB Drive coupler for 1995 SLX 780
    By koryk in forum Polaris Classifieds
    Replies: 5
    Last Post: 04-17-2010, 09:48 AM
  5. need parts for 2000 slx
    By tburn in forum Polaris PWC Performance
    Replies: 2
    Last Post: 07-10-2007, 08:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •