Results 1 to 6 of 6
  1. #1
    2000 Polaris Pro 1200 rdizz81's Avatar
    Join Date
    May 2010
    Location
    Raleigh, NC
    Posts
    315

    2000 Polaris Pro 1200 Start issues?

    Well it Ran Perfect and then the next day when i put it in water and tried to start it wouldnt turn over infact it wouldnt do anything when i hit the start button the Digital display would blink and reset... the same will happen when i push the Mode button?

    is this as simple as the battery is low? or a bad wire? any ideas?

    Also i forgot to mention...

    When i start it when it did start lol it would just pick up and go do all jetskis do this?

    there is no nuetral or reverse option but just at idle it goes and it actually moves pretty strong. making it pretty hard to start at a dock

    any ideas on this as well? is this possibly a carb or throttle adjustment?


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,601
    +1
    1,276
    Welcome

    Remove and clean both ends of both heavy battery cables.

    Pay particular attention to the engine block end of the black battery negative cable. Must be a clean metal-to-metal connection at the engine. Clean bolt, clean bolt hole threads, clean spot on the engine block.

    It is normal for a PWC to start moving forward at idle.

    You in-water idle RPM should be about 1200 to 1300 RPM, give or take. If the idle RPM is set too high, then it will want to move faster at idle.

    The Pro 1200 is a pseudo race model. That is why there is no reverse system.

  3. #3
    2000 Polaris Pro 1200 rdizz81's Avatar
    Join Date
    May 2010
    Location
    Raleigh, NC
    Posts
    315
    Awesome ill give that a shot thanks for the reply ill let you know what happens! lol

  4. #4
    2000 Polaris Pro 1200 rdizz81's Avatar
    Join Date
    May 2010
    Location
    Raleigh, NC
    Posts
    315
    Any Recommendations on what to use to clean the terminals on the battery cables or the post on the battery?

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,601
    +1
    1,276
    Quote Originally Posted by rdizz81 View Post
    Any Recommendations on what to use to clean the terminals?
    Wire brush, sandpaper, soap and water, grease remover.
    Depends on what you are trying to remove.

    Dried battery acid can be neutralized using a baking soda paste/solution.

    Wear old clothes and gloves when working with battery acid residue.

  6. #6
    2000 Polaris Pro 1200 rdizz81's Avatar
    Join Date
    May 2010
    Location
    Raleigh, NC
    Posts
    315
    They dont really look that bad... I guess at this point its just maintenence

    they do have some dirt and grime though. also is adjusting the idle something simple that i can do myself? i have noticed 3 prongs that stick out to twoards the back side of the engine that look like screws that can be turned is this how to adjust the idle?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2000 Polaris pro 1200 Issue no idea???
    By rdizz81 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 05-17-2010, 08:12 PM
  2. FS 2000 Polaris Pro 1200
    By seatsR4toilets in forum Polaris Skis
    Replies: 8
    Last Post: 10-09-2009, 06:16 PM
  3. 2000 Polaris Pro 1200 - PROJECT
    By seatsR4toilets in forum Polaris Projects
    Replies: 5
    Last Post: 10-09-2009, 02:43 PM
  4. 2000 Polaris Pro 1200 Race Ready
    By Tim Seebold in forum Polaris Classifieds
    Replies: 11
    Last Post: 11-30-2008, 02:07 AM
  5. 2000 Polaris Pro 1200
    By RollBama in forum Polaris Open Discussion
    Replies: 4
    Last Post: 08-25-2007, 02:02 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •