Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 23
  1. #1
    Jean-Paul's Avatar
    Join Date
    Jan 2010
    Location
    Greece, Athens
    Posts
    211

    Taking water in the hull ! where from ?

    hello ...

    2003 GTX sc with water problem as well

    after putting the ski in the water i tested if any water came in an if everything was ok... i turned the engine and went for a 5 minute stable ride at 30mph. then went out to check the engine compartment again... i saw some water inside though. i stopped the engine but couldn't see much. i removed the air hose below the rear seat and took a friend of mine to drive the ski while i was taking a look in the engine. first i checked the shaft and boot and carbon ring but they were tottally dry. I even pulled the boot cover so that i was able to see the ring and carbon but with 10 miles no water was coming in at all. then checked the exhaust manifold to the back and then the j-pipe. the water in the hull was salty , so it was not water from the plate and also the bottle was full.

    from where else can i be taking water in ? perhaps i didn;t look so well ? i am so dissapointed once more...

    apreciate any help .... __________________
    Jp


  2. #2

    Join Date
    May 2007
    Location
    Middleburg,FL
    Posts
    359
    +1
    1
    Does it have steering assist on it? The seals from the steering assist can leak.

  3. #3
    loopierxp's Avatar
    Join Date
    Jan 2008
    Location
    Houma, Louisiana
    Posts
    141
    I had a problem with my rxp taking on water. The problem I was having was one of the bolts holding the opas to the hull had come loose and was taking in water. It is kind of hard to see. While looking inside the hull with a flashlight I was able to barely see water trickling down the hull. Hope this helps.

  4. #4
    AaronQuade's Avatar
    Join Date
    Apr 2010
    Location
    Saint Joseph, MI
    Posts
    42
    did 2003s have opas???

    If you go back to my thread, i posted what was wrong with mine... expensive fix for me.

  5. #5
    loopierxp's Avatar
    Join Date
    Jan 2008
    Location
    Houma, Louisiana
    Posts
    141
    I wasnt paying attention to the year of the ski. Im not sure if they did or not. May also want to take a look at the bolts for the sponsons.

  6. #6
    Jean-Paul's Avatar
    Join Date
    Jan 2010
    Location
    Greece, Athens
    Posts
    211
    yap. it has opas... where should I start from so that we eliminate each case ?

  7. #7
    loopierxp's Avatar
    Join Date
    Jan 2008
    Location
    Houma, Louisiana
    Posts
    141
    Put the ski in the water. Look in the back corners of the hull with a flashlight and see if you can see a small trickle of water running down the hull. Not sure about the gtx but on my rxp it is really hard to see pass the waterbox and other hoses. How much water is it taking in?

  8. #8
    Jean-Paul's Avatar
    Join Date
    Jan 2010
    Location
    Greece, Athens
    Posts
    211
    it is very hard in mine as well !!

    in my short calm ride (around 1/2 hour) water was filling the department under the engine, it is around 8-10 cm i believe. but if i am to use it the whole day i am afraid... finding the leak is the most important thing though, not fixing it it is a pain in the A&&

  9. #9
    Jean-Paul's Avatar
    Join Date
    Jan 2010
    Location
    Greece, Athens
    Posts
    211
    i checked the sponsons and they were a little untight. I tighten them as far as I could.

    now i checked the exhaust.(my ski has removed resonator)

    in the picture you are seeing the exhaust and i have circled a pipe. is this supposed to be tapped ?is there any chance water comes in from that point ? what is that ?

    also my exhaust exits the hull without any tightenings. just with glue as you can see from the picture. is that normal ?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_1389.JPG 
Views:	70 
Size:	112.7 KB 
ID:	187047  

  10. #10
    There is supposed to be a water hose attached to that Barb. on the Exhaust exit pipe which slightly muffles the exhaust exit noise.

    Yes, water could come back in that way---slowly... but find the end of that hose and you'll find your water source...

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Water in the hull...where is it coming from?
    By kepneriphone in forum Polaris Open Discussion
    Replies: 21
    Last Post: 07-16-2013, 10:04 PM
  2. Water In The Hull
    By Duckmaster in forum Polaris Open Discussion
    Replies: 3
    Last Post: 08-11-2008, 05:25 PM
  3. Water in the hull.. how did it get there?
    By giguchan in forum Kawasaki Open Discussion
    Replies: 2
    Last Post: 06-17-2008, 12:27 AM
  4. RXP Alot of Water in the hull HELP
    By Drake in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-25-2005, 02:21 PM
  5. How much water in the hull is "normal"?
    By Pee2xUSee in forum 4-Tec Performance
    Replies: 16
    Last Post: 07-20-2005, 07:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •