Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1

    no digital gauge

    i have a 97 polaris sl780 the gauge isent working. what happend is i put in a battery. was running it for a few min watching the battery gauge to be sure it was charging then the gauge went out. checked the 2 fuses in the electrical box they were good. are there anymore fuses to check. or is it common for the gauge just to go out.


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,569
    +1
    1,272
    Welcome to the Hulk

    The MFD can fail.

    Unplug and check the connector behind the display. Look for corrosion.

    Check for battery voltage between the Red/Purple wire and the Black wire at the harness connector.

  3. #3
    ok i already checked there had the voltage so does mean its the display itself

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,569
    +1
    1,272
    Quote Originally Posted by jdogg View Post
    ok i already checked there had the voltage so does mean its the display itself
    Seems to be the case.

    Did you check for corrosion on the actual MFD pins, or inside the connector sockets?

  5. #5
    yeah it seems ok pretty clean
    were can i find mfd at and i bet they are pricey huh

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,569
    +1
    1,272
    Quote Originally Posted by jdogg View Post
    ...where can i find MFD at and i bet they are pricey huh
    You will have to hunt around.

    Price varies with condition, but good condition working examples are often $100-$200.

    If you see one on eBay, be sure others will also be bidding.

    Also watch the Classifieds here for parted out machines.

    Check with John Zigler, and perhaps post a WTB thread in the Classifieds.

  7. #7
    my skii keeps on burning mfds... i don't know why,... i better buy a tachometer and replacement fuel gauge

  8. #8

    Join Date
    Sep 2009
    Location
    Denver,NC
    Posts
    93
    Did you check the fuse with an ohmmeter? I've been burned by looking at a fuse and thinking it's good. My $.02

  9. #9
    checked it with a powerprope shows 12 volts both sides

  10. #10

    Join Date
    Sep 2009
    Location
    Denver,NC
    Posts
    93
    Quote Originally Posted by jdogg View Post
    checked it with a powerprope shows 12 volts both sides
    But, it might be back feeding. Did you physically remove the fuse?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. NO INFO GAUGE >>>HELP 2000 rx
    By Hands in forum 2-Stroke Performance
    Replies: 6
    Last Post: 04-29-2009, 02:00 PM
  2. F.S. 4-tec digital gauge
    By Discobrian24 in forum Sea Doo Classifieds
    Replies: 2
    Last Post: 02-16-2009, 09:31 PM
  3. '07+ Digital Gauge Cluster Questions...
    By duramaxxed in forum Sea Doo Sport Boats
    Replies: 10
    Last Post: 08-05-2008, 08:03 AM
  4. F/S: 4-tec Digital gauge
    By XSV in forum Sea Doo Classifieds
    Replies: 12
    Last Post: 05-15-2008, 12:35 AM
  5. Retrofitting a GSX Digital Gauge to an RXP
    By 1 FAST VE in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 12-02-2007, 11:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •