Results 1 to 6 of 6
  1. #1

    Join Date
    Nov 2009
    Location
    Tampa, FL
    Posts
    80

    STX 900 Just Died.....

    So I'm riding today in the bay near the Skyway Bridge in St. Pete, FL....awesome day, ski is running great...mild chop, mild jumps...fun....then I start putting towards a beach, just idling along and my ski simply shuts off. No sputtering, nothing...just quits....
    I drifted on into the beach and tried to start it...it turns over great just sounds like it's not getting any fuel...or spark?.....I pulled plugs (which are one week old) and they look white on the tips (Clean)....
    I pump the primer and hit the starter again and it doesn't even try to start......so I had a friend tow me back to the ramp.

    Any clue about what I could be looking at?
    2000 Kawasaki 900 STX


  2. #2
    My name is Sean and I am addicted to STXs smokeysevin's Avatar
    Join Date
    May 2008
    Location
    Houston
    Posts
    4,486
    +1
    320
    if the plugs are white that means you were running really lean, check the fuel system

    post a picture of the spark plugs

    Sean

  3. #3

    Join Date
    Nov 2009
    Location
    Tampa, FL
    Posts
    80
    I took a closer look at the plugs...they are not nearly as "White" as they looked in the sunlight.....
    I tried to test the plugs for spark though and Nothing....

    Quick question, could I have had a ground come loose (Since I was chop hopping?)...would this have killed the ski?


  4. #4

    Join Date
    Nov 2009
    Location
    Tampa, FL
    Posts
    80

    Process of Elimination (No SPark)

    Okay...tested the plug wires...No spark coming to the spark plugs...looked at the ground wire, looks fine...
    Any tips on where to go from here?

  5. #5
    PEVO's Avatar
    Join Date
    Mar 2009
    Location
    central Tx.
    Posts
    85
    I'd go to the Ebox next. Could be you got a broken fitting letting water in thus salt water cancer in the box...eaten chit up!

  6. #6

    Join Date
    Nov 2009
    Location
    Tampa, FL
    Posts
    80

    Took it in to the shop

    Just got a call from the local shop. Mechanic says I need to look for a CDI Box, DC converter and Regulator Rectifier......
    Where do I start the search?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. just dying to hear some numbers on that 300hp fuel system.
    By theantiRXP in forum 4-Tec Performance
    Replies: 16
    Last Post: 01-14-2012, 11:16 PM
  2. New to the forums... my 2000 Speedster just died :( Help?
    By Boss in forum Sea Doo Sport Boats
    Replies: 4
    Last Post: 08-03-2007, 10:24 AM
  3. New to the forums... my 2000 Speedster just died :( Help?
    By Boss in forum Sea Doo Sport Boats
    Replies: 5
    Last Post: 07-27-2007, 08:39 PM
  4. 99 stx 900 Need help with engine!!! HELP!!!!
    By gvnitup in forum Kawasaki Open Discussion
    Replies: 4
    Last Post: 07-11-2007, 04:00 PM
  5. Just dies while cruising
    By mea43 in forum Yamaha Old School Skis
    Replies: 10
    Last Post: 05-23-2007, 07:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •