Results 1 to 8 of 8
  1. #1
    Flynfox's Avatar
    Join Date
    Aug 2006
    Location
    Sunny SC
    Posts
    682

    RXP Sat Way Too Long!

    Well guys I purchased a '06 RXP new & only got to put 20 hrs on it before it sat for over a year Long story short it was completely unexpected & somewhat unavoidable. In fact this is my first log in since May '09.

    The battery will charge but the ski won't crank; I'm guessing bad gas and/or gunked up fuel system. So now that summertime is back & I'm able to enjoy my RXP I've decided to get it back into shape. It has the full Stg I Riva kit, all the free mods & a few other extras. It looks brand new, well actually it is (20 hrs) & I'm ready to ride. I even had to pay 2 yrs worth of property taxes on it; again long story.

    Next week I will take it to the shop for an oil change & inspection before I take it out. I'm absolutely terrified abt sinking and/or getting stranded in my area with all the gators, snakes etc! Yeah I'm a chicken

    So anything I need to know abt guys?

    Thanks in advance for your help,
    Rob


  2. #2
    Big K's son KeithKman's Avatar
    Join Date
    Dec 2006
    Location
    Southern California
    Posts
    1,735
    Change the plugs, oil, and make sure the battery holds a good charge. Fresh gas. Ride.

  3. #3
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    take a buddy with you too

  4. #4
    YoYamma's Avatar
    Join Date
    Aug 2006
    Location
    Central Florida
    Posts
    21,570
    +1
    4,788
    Quote Originally Posted by Flynfox View Post
    Next week I will take it to the shop for an oil change & inspection before I take it out.
    Make sure those ceramic clutch washers are out of there before you start it again; you need to replace those with the Riva metal washers (now). Read this:
    http://www.greenhulk.net/forums/showthread.php?t=19887

    Quote Originally Posted by Flynfox View Post
    I'm absolutely terrified abt sinking and/or getting stranded in my area with all the gators, snakes etc!
    Come on grow a pair will ya?


  5. #5
    Flynfox's Avatar
    Join Date
    Aug 2006
    Location
    Sunny SC
    Posts
    682
    Thanks for the input everybody.

    YoYamma - I ditched those washers before the ski was even broken in I'm an analyst by nature so I luv to read & study. When I learned of all the horror stories abt those washers I parked the ski & ditched them right away

  6. #6
    YoYamma's Avatar
    Join Date
    Aug 2006
    Location
    Central Florida
    Posts
    21,570
    +1
    4,788
    Smart man!

  7. #7
    Sinecure's Avatar
    Join Date
    Mar 2010
    Location
    Houma, LA
    Posts
    41
    +1
    2
    Quote Originally Posted by Flynfox View Post
    The battery will charge but the ski won't crank; I'm guessing bad gas and/or gunked up fuel system.
    Does the engine turn over and it doesn't fire, or is it not even turning over. Is the display coming on and do you hear the fuel pump & beeps?

    If you're getting a display and hearing beeps, but engine isn't turning over, you may want to get that battery load tested. It's probably toast.

  8. #8
    Flynfox's Avatar
    Join Date
    Aug 2006
    Location
    Sunny SC
    Posts
    682
    Quote Originally Posted by Sinecure View Post
    Does the engine turn over and it doesn't fire, or is it not even turning over. Is the display coming on and do you hear the fuel pump & beeps?

    If you're getting a display and hearing beeps, but engine isn't turning over, you may want to get that battery load tested. It's probably toast.
    The engine turns over fine & everything works it just won't fire. I'm pretty sure it's just bad gas so I'm dropping it off Wednesday to my friendly SeaDoo dealer, they r really great guys. They pretty much told me the same thing too. I also have a new battery & new plugs on the way.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New drive shaft in 2005 RXP too long? Need help asap.
    By pjv911 in forum 4-Tec Performance
    Replies: 20
    Last Post: 03-25-2013, 08:15 AM
  2. SLT750 Extended Pump Install - Are My Bolts Too Long??
    By way2much2do in forum Polaris Open Discussion
    Replies: 7
    Last Post: 07-22-2009, 05:37 PM
  3. Is there any way too...?
    By lludacrisboy in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 12-03-2007, 11:40 PM
  4. Way too funny
    By Lvnspeed in forum Videos & Pictures
    Replies: 10
    Last Post: 09-07-2006, 08:54 PM
  5. This is way too funny!!!...
    By VFX_Artist in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 10-07-2005, 02:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •