Results 1 to 9 of 9
  1. #1

    depitch impeller loss top end speed 1 mph

    today , i depitch my skis 15/22R impeller 1mm , after depicth i test my skis , i get the result : RPM8600 GPS78MPH , last time i use 15/22r impeller and use 83mm nozzle my result : RPM8440 GPS79.1MPH , i lost the 1mph, i dont know why i depitch 1mm , can get extra RPM but top end speed lost,my country weather is 34c water temp 30c, any guys have good idea can get extra 2-3mph ??????


  2. #2

    Join Date
    Oct 2009
    Location
    miami
    Posts
    715
    something is wrong i dont even have a ecu and i go 80+

  3. #3

    Join Date
    Oct 2009
    Location
    miami
    Posts
    715
    u should be in the 80`s with that can anyone else chime in

  4. #4
    Huh? Dyoung's Avatar
    Join Date
    May 2009
    Location
    Pt. Neches , Texas
    Posts
    1,021
    +1
    25
    Quote Originally Posted by stevorxp007 View Post
    u should be in the 80`s with that can anyone else chime in
    he's running 79 on a t-x, thats pretty quick imo

  5. #5
    Big K's son KeithKman's Avatar
    Join Date
    Dec 2006
    Location
    Southern California
    Posts
    1,735
    You make the common mistake of pitching the prop the opposite way?

  6. #6
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    He has a Couch not a two seater Steve. Sounds like there is some type of climate change and or water condition change that is hurting him since his RPM's are actually up a bit and theoretically his speed should be to.

    You used the same nozzle for both runs correct?

  7. #7
    yes ! I same nozzle size is 83mm, but before i depitch i test the skis water temp is 26c today i test water temp is 30c , i very surprise after depitch can get more RPM why top end speed lost 1 mph, chance nozzle to 82mm can improve top end performance ???

  8. #8
    home of the dislexic fingers breon's Avatar
    Join Date
    Aug 2007
    Location
    port st lucie fl
    Posts
    3,471
    82 will decrease rpm...i would go back and look at the prop again remeasure and make sure they are all the smae you may have one out and making it inefficiant...temp currents fuel ect all affect things especially when you are pushing the top end of speed

  9. #9
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    Quote Originally Posted by breon View Post
    82 will decrease rpm...i would go back and look at the prop again remeasure and make sure they are all the smae you may have one out and making it inefficiant...temp currents fuel ect all affect things especially when you are pushing the top end of speed
    I'm thinking boost leak, wear ring worn , or nose come on prop loose.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 900 STX loss of top end speed
    By Gkulp in forum Kawasaki PWC Performance (2-stroke)
    Replies: 5
    Last Post: 08-17-2016, 07:20 AM
  2. 2008 SEA DOO GTX 215 - top end speed loss
    By slnranger23 in forum 4-Tec Performance
    Replies: 13
    Last Post: 08-23-2013, 07:13 AM
  3. rxt 215 loss top end speed
    By thomas loh in forum 4-Tec Performance
    Replies: 0
    Last Post: 08-15-2010, 04:05 AM
  4. loss of top end speed
    By jrbonniwell in forum Kawasaki PWC Performance (4-stroke)
    Replies: 13
    Last Post: 07-08-2008, 12:34 PM
  5. Which OEM impeller for top end speed?
    By lee in forum 4-Tec Performance
    Replies: 5
    Last Post: 10-02-2007, 07:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •