Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 24
  1. #1

    towed my RXT for 20 miles at 40+MPH

    so my ski left me stranded FAR from the dock due to "low voltage"... I havent even tried to fix this issue yet..

    my question is.. The ski was towed for a long time at high speeds. I did not know i was supposed to close off the hose.. i found out reading some threads.. so after that i charged the batery and the ski started although rough at first..
    I flushed it etc. the next day and i have started her up a few times dry and she starts right up and everything seems normal... am i missing something? i have not put the ski in the water to try it.. so shold i ckeck anything? maintenence? any help on if i messed my ski up by towing it so long and fast would be a great help.
    its a 2005 RXT with 65hrs

    FYI i was towed by a seadoo jetboat with 430hp and the guy was going flat out for a while.. i had no choice cause i was really far from land.


  2. #2

    Join Date
    Apr 2008
    Location
    Plainfield, IL
    Posts
    1,237
    +1
    10
    Check for water in the oil. Im sure it ingested water is he was flying. O jeez.

  3. #3
    GOT BOOST? Dockside's Avatar
    Join Date
    Dec 2008
    Location
    Ontario, Canada
    Posts
    3,879
    +1
    116
    my guess is you got water in the motor. hope there was no water in the cylinders and you didnt bend a valve when you started it.

  4. #4
    Bow chicka wow wow
    Join Date
    Sep 2006
    Location
    Charlotte,NC
    Posts
    490
    +1
    5
    Man I had the same thing happen to me on my 06RXP. It left me stranded, a guy came by on a couch(honda) and said he would tow me back. I told him idle speed only because I did not have the pincher. Oh hell no, he pulls me wide open, which for him was only 55mph. I just said what the heck and started it when I got on the trailer. All the water blew right out, obviously none in the engine and that was 100 hours ago. At the time my exhaust water box was stock, if not, I'm sure it would have ruined by engine.

  5. #5

  6. #6

    Join Date
    Nov 2009
    Location
    Central CT
    Posts
    92
    +1
    2
    I did a search on what hose to block off to prevent water coming in when being towed and couldn't find anything.

    Anyone know what hose to block off? Pics?

    What would you use to block off/pinch the hose?

    I can't find my owner's manual. Any help would be appreciated. Thank you.

  7. #7
    mbaseball3's Avatar
    Join Date
    Jun 2007
    Location
    stockton, ca
    Posts
    748
    +1
    21

    Re: towed my RXT for 20 miles at 40+MPH

    I did a search on what hose to block off to prevent water coming in when being towed and couldn't find anything.

    Anyone know what hose to block off? Pics?

    What would you use to block off/pinch the hose?

    I can't find my owner's manual. Any help would be appreciated. Thank you.
    Get a groco water strainer and shut off valve then you'll be good to go.


    Sent from my HTC Hero using Tapatalk

  8. #8

    Join Date
    Apr 2008
    Location
    Plainfield, IL
    Posts
    1,237
    +1
    10
    Here is a pic of my old strainer setup. The hose that comes from the right side of the back of the ski in my pic. Right next to the arrow is your water into the ski. Put a valve like I did.

  9. #9

    Join Date
    Apr 2008
    Location
    Plainfield, IL
    Posts
    1,237
    +1
    10
    Someone correct me if the RXT is different.

  10. #10
    so my RXT is stock.. and i checked the oil and there is no water in it..

    so is my ski ok?? do i need to take it apart or something? should i try it out in the water?

    I was told that since my ski is stock i really should not have a problem with this...??

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB - Parts Looking for a good shape 15/20 for my RXT
    By race24x in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 05-08-2012, 09:01 PM
  2. Yamaha 1200 cutting off at 40 mph
    By hoodwink in forum Yamaha How To & FAQs
    Replies: 1
    Last Post: 05-10-2009, 10:51 AM
  3. WTB Impeller for my RXT around 15/20 pitch
    By Gus13letter in forum Sea Doo Classifieds
    Replies: 8
    Last Post: 11-25-2008, 01:06 PM
  4. Sneeky speed increase for my RXT
    By La Reine a` Sea Doo in forum 4-Tec Performance
    Replies: 32
    Last Post: 12-04-2006, 11:02 AM
  5. is that MY wife I see towing MY RXT....BACKWARDS?!?!?!
    By SKR8PN in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 06-06-2005, 11:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •