Results 1 to 2 of 2
  1. #1
    Firefighterarcher's Avatar
    Join Date
    Nov 2008
    Pinson, Alabama

    Questions about MFD 95 Sl750

    The MFD is acting funny, only time it will show information is when you hit the buttons. It goes into calibration mode runs the check and then the MFD shuts off any ideas? Think I posted the first on in the wrong area.

  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    near Toronto, Canada
    Does it show RPM when the engine is running, after you push a button?

    Unplug the MFD connector on the back side, check for corrosion on the pins and in the connector contacts.

    Then check the Yellow wires in the electrical box. Make sure there is no corrosion in the electrical box.

    Check or replace the 1/4 Amp MFD fuse while you are in there.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. MFD's anybody?
    By ph2ocraft in forum Polaris Open Discussion
    Replies: 14
    Last Post: 05-05-2012, 07:02 PM
  2. SL750 Steering and MFD
    By AISTROP in forum Polaris PWC Performance
    Replies: 2
    Last Post: 07-31-2007, 06:52 PM
  3. Polaris sl750 questions (waterleak and trim)
    By smittyj77 in forum Polaris Open Discussion
    Replies: 10
    Last Post: 05-24-2007, 03:52 PM
  4. Newbie who purchased a 1995 Polaris SL750 and have some questions
    By Great_Outdoors_5911 in forum Polaris Open Discussion
    Replies: 3
    Last Post: 05-18-2007, 10:19 PM
  5. 95 sl750 questions
    By 95 sl750 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 04-16-2007, 05:20 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts