Results 1 to 4 of 4
  1. #1
    oct6454's Avatar
    Join Date
    Sep 2008
    Location
    Gig Habor, Washington
    Posts
    758
    +1
    8

    2003 GTI Possible Starter Problems?

    So, taking the ski out washed and prepped them for the summer. My 99xpl fired right up. My 2003 GTI (usually the one that runs) Won't start. The battery is fully charged and when the push the start button all you get is the sound of a power drill with a few knocking sounds. Which stop and the ski lets off a loud beep. and won't turn over until you remove the key. The knocking isn't loud like when you battery can't turn it over its very quiet and in rapid succession. Has the started or solenoid gone bad?
    Thanks:Oliver


  2. #2
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,530
    +1
    1,281
    clean the battery terminals and get a voltmeter on the battery..sounds like the battery can't push any power

  3. #3
    oct6454's Avatar
    Join Date
    Sep 2008
    Location
    Gig Habor, Washington
    Posts
    758
    +1
    8
    I put the volt meter on and it reads 11 volts.

  4. #4
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,530
    +1
    1,281
    if it's reading 11 volts just sitting there, it needs a new battery. try charging that one first. it should read 12.3->13 after coming off the charger,

    right now if you hit the starter button, I'm confident the voltage will drop to like 7 or 8

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. GTI Starter Problem
    By osubrenden in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 06-20-2014, 04:24 PM
  2. Possible ECU problems 2003 GTX 4TEC
    By OSDmarine in forum Sea Doo ECU Support
    Replies: 5
    Last Post: 12-06-2013, 12:49 AM
  3. Possible starter relay problem
    By gms05rxt in forum 4-Tec Performance
    Replies: 11
    Last Post: 01-01-2009, 12:30 PM
  4. '97 1100 STX starter problem
    By lil8znguy in forum Kawasaki How To & FAQs
    Replies: 0
    Last Post: 05-10-2007, 03:32 PM
  5. Bad switch or starter problems on 04 RXP.
    By MikeTrin in forum Sea Doo Open Discussion
    Replies: 15
    Last Post: 05-22-2006, 12:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •