Results 1 to 8 of 8
  1. #1

    video of my 97 xp 787 on water & trailer. what is wrong with it?

    i have 97 xp 787 premix. my rotary oil line busted one day and all this started to happen, leaking rave, smokey engine, diesel sound, cant run hi RPMs.

    land


    water


  2. #2
    Deanrw3's Avatar
    Join Date
    Oct 2008
    Location
    west MI
    Posts
    249
    The first video sounds fine from what i can hear -- im no expert.

    The second video it is clear you have some bogging . So you are either getting too much fuel or oil is leaking into the engine somewhere causing the bog sound when you take off.

    Does the bog ever clear out and you can reach some rpms?

    What do your spark plugs look like after your run on the water?

    What is your low speed screw set at and what is your jetting?

    Since your rotary valve oil line blew off have you pulled the rotary valve cover/carbs to inspect the valve? That would be my first move. The rotary valve is metal spinning past metal which is lubricated by that oil line, it could have seized/worn down causing excessive gap on the rotary valve.

    Did you ever figure out the leaking rotary valve / pipe? I can see a lot of oil/gas on the engine in video 1?


    Dean

  3. #3
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    as dean asked...can you plane out and reach full RPM's?

    also, is your waterbox hard jetted? you may be loading up...

  4. #4
    JayZ's Avatar
    Join Date
    Feb 2006
    Location
    mississauga, ontario
    Posts
    407
    +1
    1
    almost looks like you have an exhaust leak and that is choking out the engine.

  5. #5

    Join Date
    Sep 2009
    Location
    Windsor, ON
    Posts
    54
    Also, try running it on the water with the seat off. It will let more air in. If your exhaust leak is choking the engine, this may help in the troubleshooting as more air will get in the compartment and thin out the exhaust

  6. #6
    maxadrenaline's Avatar
    Join Date
    Nov 2007
    Location
    RETIRED !! In Mobile AL or Wherever I Want To Go
    Posts
    1,414
    +1
    137

    Rave Valve Diaphrams

    Also you might check to see if your rubber diaphrams on your rave valve caps have come off of the tops. That will not allow the valves to work as they should and limit your rpms. One of mine popped off the other day and dropped the rpms 200. If so, clean the rubber really good with windex and put it back on.

  7. #7
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Check your midpipe jet for clogging, and then your coupler for a split under the bottom. If the coupler is split, (from melting due to the clogged jet) it will bog just like a carb problem and run like crap. Been there done that.

  8. #8
    No full rpms

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Can anyone please tell me what is wrong with my GTI LE RFI
    By bunks in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 05-21-2013, 08:55 AM
  2. Cant figure out what is wrong with my 92 sl 650
    By kalina101 in forum Polaris PWC Performance
    Replies: 1
    Last Post: 09-05-2011, 09:37 PM
  3. What is wrong with my 2011 RXT-X? Blown SC??
    By bankerii in forum Sea Doo Open Discussion
    Replies: 20
    Last Post: 05-05-2011, 09:05 PM
  4. 97 xp taking on water/wear ring
    By diesel04 in forum 2-Stroke Performance
    Replies: 2
    Last Post: 08-02-2010, 05:41 PM
  5. what is wrong with my rxp???
    By sc281rxp in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 08-05-2008, 02:58 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •