Results 1 to 6 of 6
  1. #1

    First Ski = 05 STXR - Please Help with Questions

    Hey guys, I'm new! I just got my first ski... it is a 2005 STXR 1200 with only 30 hours on it with a few performance parts on it as well. It came with R&D red colored heads, umi steering kit, R&D ride plate, Riva Runabout bars, umi trigger, and a Riva seat cover... He also rigged up a tripple pisser on the right side in the rear. It also has a flush kit thing with a cutoff valve and he ran it up to the front where I can hook the hose up under the green hatch.... It also has dual cooling?? he said he pinched one of the lines off a bit though because it was running too cool... what do ya think? I got it for 3,650 with a trailer.. the fiberglass, hull, paint and plastics all look great too! its always been in a garage... Good deal??

    Ok here are a couple issues after riding it more. It runs really strong, but if you idle around for a while and then try to nail it, it kind of revs a little choppy when its coming up to the powerband and then runs a little rough up top around 5500 6,000 rpm like it has too much fuel or soemthing from idling, but it does smooth out pretty quick... and then it pulls really hard up top... When you are riding it hard though like turning and doing donuts and jumping waves it is really smooth and very powerful. It is not choppy or burbly at all... it feels great! So does it need some more tuning or is that kind of normal? Is it getting too much fuel while idling or something?

    Today we were in the river and it was really choppy. 3 people total. We could only go about 30-35 mph because we kept jumping out of the water and couldnt get speed because it was losing suction... plus it was hard on us. Am I doing something wrong like the way im driving or do they just not run that well with a lot of weight and choppy water... Also, during that ride session... the low oil light came on and it was blinking. So i stopped and pulled the front box thing out and checked it. It looked good, so i cut it off and then fired it back up and it was fine. The light went away. Is that a sensor problem or an oil injection problem? Because the gauge said that its got about half to 3/4 full....Also do yall pour more oil into the fuel "just to be safe" thats what the last owner said he did.

    The other thing is the steering.. the handle bars are a little off. Its like I have to turn right a little to make it go straight. Do yall think I just need to unscrew them and set them straight? Kind of like an alignment with tierods on a car or is it another issue?

    Any other advice or stuff I should do to it to make it run at its best? I dont know a thing about ski's. I work on my own cars and stuff, so im not afraid to tackle something new.. I just need a little direction. What stuff should I spray the motor with to keep it protected? After being in the salt, should I always spray the motor down with water and all around the cdi box and up front and everywhere and let it drain? Is all of that stuff waterproof?

    Sorry this post is soo long and i have a lot of questions... im just trying to learn.


  2. #2
    Quote Originally Posted by BadBowtie03 View Post
    Hey guys, I'm new! I just got my first ski... it is a 2005 STXR 1200 with only 30 hours on it with a few performance parts on it as well. It came with R&D red colored heads, umi steering kit, R&D ride plate, Riva Runabout bars, umi trigger, and a Riva seat cover... He also rigged up a tripple pisser on the right side in the rear. It also has a flush kit thing with a cutoff valve and he ran it up to the front where I can hook the hose up under the green hatch.... It also has dual cooling?? he said he pinched one of the lines off a bit though because it was running too cool... what do ya think? I got it for 3,650 with a trailer.. the fiberglass, hull, paint and plastics all look great too! its always been in a garage... Good deal??

    Ok here are a couple issues after riding it more. It runs really strong, but if you idle around for a while and then try to nail it, it kind of revs a little choppy when its coming up to the powerband and then runs a little rough up top around 5500 6,000 rpm like it has too much fuel or soemthing from idling, but it does smooth out pretty quick... and then it pulls really hard up top... When you are riding it hard though like turning and doing donuts and jumping waves it is really smooth and very powerful. It is not choppy or burbly at all... it feels great! So does it need some more tuning or is that kind of normal? Is it getting too much fuel while idling or something?

    Today we were in the river and it was really choppy. 3 people total. We could only go about 30-35 mph because we kept jumping out of the water and couldnt get speed because it was losing suction... plus it was hard on us. Am I doing something wrong like the way im driving or do they just not run that well with a lot of weight and choppy water... Also, during that ride session... the low oil light came on and it was blinking. So i stopped and pulled the front box thing out and checked it. It looked good, so i cut it off and then fired it back up and it was fine. The light went away. Is that a sensor problem or an oil injection problem? Also do yall pour more oil into the fuel "just to be safe" thats what the last owner said he did.

    The other thing is the steering.. the handle bars are a little off. Its like I have to turn right a little to make it go straight. Do yall think I just need to unscrew them and set them straight? Kind of like an alignment with tierods on a car or is it another issue?

    Any other advice or stuff I should do to it to make it run at its best? I dont know a thing about ski's. I work on my own cars and stuff, so im not afraid to tackle something new.. I just need a little direction. What stuff should I spray the motor with to keep it protected? After being in the salt, should I always spray the motor down with water and all around the cdi box and up front and everywhere and let it drain? Is all of that stuff waterproof?

    Sorry this post is soo long and i have a lot of questions... im just trying to learn.
    Good deal? Sounds like it. this is the last year they made this partucular model. If you had 3 people on it in choppy water; you had too much weight / too many people on the boat. This boat I believe was sold as a "3 seater" but in reality it is really just a 1 person "race boat" which had a long hull (compared to other manufactureres hulls during this time period). If you still want to ride 2 or 3 up I would put a different ride plate on it. I think a stock ride plate from a KAW 15F will bolt onto that boat. It will slow the boat down but it will get rid of some of that "pogo stick" bouncing you are describing. Sounds like the boat has some higher compression heads on it; for that reason I would always put at least 91 octane in it (or even higher if the old owner told you different). I do not think you need to put any extra oil in the Tank; you run the risk of fouling the spark plugs. Plus some of that low end sluggishness you are describing could be from oil in the Tank. If you fill your oil tank to the top you should get about 3 tanks of gas B 4 the oil warning light comes on. I never let the oil tank get less than half full. What you have is a hull that is really designed for close course racing, but it does pretty good (not really good) in other types of water too. I had the 2002 and 2004 model of this boat so your Post does bring back some fond memories. Maybe some other people can chime in about some of your other questions. I liked the color on the 2005 model; it's a real "kawasaki green". JB

  3. #3
    Hey thanks for the reply and yes I am only running high octane in it. The other owner did as well... I dont think that I want to sacrifice performance so that I can carry more people, but we will see as time passes how many times I have friends on it with me. I agree, this thing handles amazing! It sticks like glue to the water! I cant get it to slide hardly at all... under hard throttle and cornering it just flat goes!

    I will definitely start keeping the oil tank as full as possible... so you dont think I have a problem? You think it was just the rough water or what? And yeah, it fits 3 people easily.. like you said it was marketed that way, but it definitely feels best with just me on it.

    You think that rough running could just be the oil like you said or could it need tuning in the carbs or something? Are they prone to "loading up" with fuel when they idle for a little bit? Also, it will die if it idles too long... not for about 30-45 seconds though. Should I turn the idle up with that little stick or is that another problem? thanks for the help!

  4. #4
    Quote Originally Posted by BadBowtie03 View Post
    Hey thanks for the reply and yes I am only running high octane in it. The other owner did as well... I dont think that I want to sacrifice performance so that I can carry more people, but we will see as time passes how many times I have friends on it with me. I agree, this thing handles amazing! It sticks like glue to the water! I cant get it to slide hardly at all... under hard throttle and cornering it just flat goes!

    I will definitely start keeping the oil tank as full as possible... so you dont think I have a problem? You think it was just the rough water or what? And yeah, it fits 3 people easily.. like you said it was marketed that way, but it definitely feels best with just me on it.

    You think that rough running could just be the oil like you said or could it need tuning in the carbs or something? Are they prone to "loading up" with fuel when they idle for a little bit? Also, it will die if it idles too long... not for about 30-45 seconds though. Should I turn the idle up with that little stick or is that another problem? thanks for the help!
    Between my 2002 and 2004 I had about 500 hours of saddle time; I always found that the stock Carbs worked pretty well . . even at higher elevations. I would change the spark plugs; I think that boat takes an NGK BR9ES if I remember correctly. And I think no oil in the gas! On the pwctoday.com main menu under Industry Leader Section / GoupK harry Klemm, that is a section dedicated to boats just like yours. They know the "ins and outs" of this boat pretty well. I woild Post something there and you can get a good response about your detailed engine questions. JB

  5. #5
    jonny5's Avatar
    Join Date
    Aug 2005
    Location
    Redding, CA
    Posts
    1,266
    +1
    5
    Run the Br9es plugs NGK... 91 octane because of the R&D heads and no added oil in the fuel tank just fuel injection.

    The R&D ride plate will make the ski porpoise from about the 35mph zone even worse with 2 or 3 up....but the stock ride plate will get rid of that.

    The ski is a 3 seater but was more built for racing. But I have riding 2 people many times and does fine. It was originally a 3 seater based from the stx-DI hull which is now the same hull for the stxr 15F and 12F...

    Hope this helps you got a great ski and a good deal.

  6. #6
    thanks for the help guys... i will pull the plugs and see what they look like and which ones they are. He said they were new about 3 or 4 hours ago and they look clean and white on top like they are new... but you never know.

    Also, what amsoil oil should i run in her? Should I even spend that much on oil? yall think it is worth it?

    So yall dont think the choppyness is anything else? only the plugs? thanks

    any other advice on my other questions? what about what stuff I should use to protect the motor and how much I should wash it out around under the hatch?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Please help with hours on ski.
    By amf133 in forum Yamaha How To & FAQs
    Replies: 5
    Last Post: 06-22-2015, 10:16 AM
  2. First Problems!!!! Please Help With 2012 FX Cruiser SHO???
    By mjealey in forum Yamaha PWC Performance (4-stroke)
    Replies: 49
    Last Post: 12-12-2013, 05:36 PM
  3. WTB emergency stuck in the water!!! please help with 05 rxp !
    By bksbigboy69 in forum Sea Doo Classifieds
    Replies: 11
    Last Post: 07-10-2011, 05:07 AM
  4. Questions on which ski to buy...please help!!
    By Thor7000 in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 07-31-2010, 10:31 PM
  5. Please Help with 1999 Polaris Genesis carbureted ski.
    By K-9 in forum Polaris How To & FAQs
    Replies: 15
    Last Post: 05-09-2010, 01:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •