Results 1 to 2 of 2
  1. #1

    2004 msx 110 shuts off after 2 minutes

    Need a little help, have a 04 msx 110 43 hours. I just installed a new turbo, it runs great for about two minutes then it just shuts off. It isnt going into sleep mode, there is no check engine light. It dosent matter if you are going 40 mph, or just idleing on the water hose. It shuts off, you hit the start button and it fires right back up. Does anyone have any ideas? I'm not sure if the 2 minutes is exact, but it is close. Please....


  2. #2

    won't stay running

    I just repaired 1 that was doing the exact same thing it was the wastegate accuator. hope hat helps. trouble code # was PO 234

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2001 Virage TX Shuts Off After 30 Minutes of Riding
    By Nick Sortor in forum Polaris How To & FAQs
    Replies: 11
    Last Post: 07-22-2016, 02:44 PM
  2. MSX 110 shuts off but restarts easily. Help please.
    By blackened21 in forum MSX/Matrix
    Replies: 39
    Last Post: 06-22-2016, 08:50 PM
  3. MXS 110 shuts down after 2 minutes
    By Mert in forum MSX/Matrix
    Replies: 11
    Last Post: 06-24-2013, 10:15 PM
  4. Replies: 4
    Last Post: 09-02-2008, 08:37 PM
  5. 2004 msx 110
    By posfit in forum Polaris Open Discussion
    Replies: 5
    Last Post: 05-26-2007, 06:40 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •