Results 1 to 6 of 6
  1. #1
    slydogge's Avatar
    Join Date
    Jul 2009
    Location
    Florida
    Posts
    306

    what springs are used with the riva valves?

    Hey guys after much troubleshooting I found that the springs that come with the riva parts kit cant be the early red springs or the late model green springs. ski had a bad bog when you nail it up to about 4500-5000 for a couple seconds then would shoot off.

    I took the green springs that were a little stiffer than the red springs and I stretched them out about an extra inch on the two valves I could get to easiest thing shot out of the water with almost no bog and now has a small hesitation around 6000 rpm. These were the only two springs I could see that seadoo makes

    Maybe does anyone know the length of the riva springs? The green spring is clearly a bit stronger than the small red springs of early seadoo's.

    clearly the oem red and green springs must not be the same spring rate riva sells with the parts kit or there is something crazy about my boat.

    Now the reason I did not buy the parts kit is because I can get all the seadoo parts for each valve for about $50 at dealer cost. I called riva and they claim they do not sell just the spring so they sent me to the tech line that was busy so I left them a voicemail and they never called back today.

    Hope someone can help! Please!


  2. #2
    slydogge's Avatar
    Join Date
    Jul 2009
    Location
    Florida
    Posts
    306
    I am finding that there were a few different springs that were used on the waterbox rave valve through the years im wondering if they used one of those that worked well on the 1200/1300 boats... hmm

  3. #3
    slydogge's Avatar
    Join Date
    Jul 2009
    Location
    Florida
    Posts
    306
    Well I talked to riva and the parts guy said he thinks they are 420939136 seadoo springs but I have tried those and they seem to be the softest of all the springs... hmmm

  4. #4
    slydogge's Avatar
    Join Date
    Jul 2009
    Location
    Florida
    Posts
    306
    well incase anyone searches for this and finds it the answer is 420939136. I put them in and still have a bog for a few seconds out of the gate... wonder if you have to do the island racing holeshot kit or something similar to it to use the riva valves.... hmmm

  5. #5
    JetSkiDaddy's Avatar
    Join Date
    May 2005
    Location
    Houston, TX
    Posts
    1,418
    +1
    4
    Did you adjust the cap ?

  6. #6
    slydogge's Avatar
    Join Date
    Jul 2009
    Location
    Florida
    Posts
    306
    Yep 1/2 turn at a time. No change. I have tried 3 different springs

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 2
    Last Post: 05-11-2010, 12:17 PM
  2. What Turbos are used On the Ultra 250/60x
    By Kiwi Racer in forum Kawasaki PWC Performance (4-stroke)
    Replies: 25
    Last Post: 01-10-2010, 10:15 PM
  3. What's up with the Riva brackets & the P-X
    By pdxrealtor in forum 4-Tec Performance
    Replies: 15
    Last Post: 05-04-2009, 06:43 PM
  4. What is up with the Riva website?
    By o uncola o in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 08-30-2008, 06:36 PM
  5. What oil to use with new metal washers?
    By Jarrett in forum 4-Tec Performance
    Replies: 22
    Last Post: 09-09-2006, 05:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •