Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1
    Matrix 200 suparoo's Avatar
    Join Date
    Dec 2007
    Location
    Nelson, New Zealand
    Posts
    262

    Matrix Water Inlet Manifold Corrision

    Just a note to let anyone that has a Matrix to check the water inlet manifold that on mine was fitted into the gap under the left hand foot well.
    While doing some off season maintenance I found that it was so badly corroded on the outside from salt water that it wasn't far off going into holes.
    When it was fitted the foam under the foot well was removed and the manifold was put in there and held in place with some spray foam and allowed to cure. Unfortunaltly this foam seems to hold water and all my riding is in salt hence its started to corrode.
    My fix was to remove it and bead blast of all the corrosion. I then got some "closed cell foam" (non water exsorbing) and folded it in half to make an envolope which I pushed into the gap where the manifold was. I then sealed that in place with some spray foam with the mainfold sitting inside it so any water that gets around the manifold can be washed and drained but still holding it in place resonably firmly.
    Sorry forgot to take pics while I was doing it.

    John


  2. #2

    Join Date
    Jun 2008
    Location
    Bullhead City AZ.
    Posts
    451
    +1
    2
    Got any Pics

  3. #3

    Join Date
    Jun 2008
    Location
    Bullhead City AZ.
    Posts
    451
    +1
    2
    I will have to check mine

  4. #4
    Matrix 200 suparoo's Avatar
    Join Date
    Dec 2007
    Location
    Nelson, New Zealand
    Posts
    262
    Sorry no pics. Camera was at work the day I did it. Not sure if all the Matrix's were assemble in this fashion but the two N.Z ones were.
    Check your PTO exhaust hose while you are at it, the one between the stinger and waterbox. Mine had a hole right where the reverse bucket cable go past it.

  5. #5
    I'm feeling naturally aspirated today pirate33's Avatar
    Join Date
    Aug 2006
    Location
    Lomita, aka Slowmita
    Posts
    1,932
    +1
    7
    You mean this one John?
    John how do you back flush your Matrix?

    Also John check all the Triple Pipes under every connector as I don't believe they can be flush out correctly under the hoses and water could just sit

    Don't forget this one that sits in what looks like Hydro-turf since it is at the bottom of the low point in the hull below the drive shaft, also the water out hose from here to the exit on the hull I replaced as it was very hard when you pinched it between your fingers

  6. #6
    I'm feeling naturally aspirated today pirate33's Avatar
    Join Date
    Aug 2006
    Location
    Lomita, aka Slowmita
    Posts
    1,932
    +1
    7
    Quote Originally Posted by lovehavenfun View Post
    Got any Pics
    Do you have any pic's of your ski I don't think I've seen them as I missed meeting you at the WF's last year, would love to see it

  7. #7
    Matrix 200 suparoo's Avatar
    Join Date
    Dec 2007
    Location
    Nelson, New Zealand
    Posts
    262
    Thats the one, installed exactally the same as mine. I need to get to bottom one next time I have the pipes out.
    To flush mine - its had a flush kit installed on the inlet from the pump and I clamp of behind it so as to force the water through the system.

  8. #8
    800AMSOIL4U's Avatar
    Join Date
    Aug 2006
    Location
    Morgan Hill, CA
    Posts
    5,024
    +1
    132
    Pirate how many times do Al and I need to tell you? :P This is the flush kit you need to go into the pissers. AWAC170 This flushes it backwards

    http://www.hotproductsusa.com/PDFs/H...line_Bilge.pdf

  9. #9
    Matrix 200 suparoo's Avatar
    Join Date
    Dec 2007
    Location
    Nelson, New Zealand
    Posts
    262
    Going into the pisser doesnt seem logical to me as thats the opposite way the way would normally go. Mines one of the first ones on the picture "TEEd" into the hose from the pump. I need to get round to putting a plastic valve in to stop the water going back out the pump at the moment I just clamp off the hose going back.

  10. #10
    800AMSOIL4U's Avatar
    Join Date
    Aug 2006
    Location
    Morgan Hill, CA
    Posts
    5,024
    +1
    132
    Quote Originally Posted by suparoo View Post
    Going into the pisser doesnt seem logical to me as thats the opposite way the way would normally go. Mines one of the first ones on the picture "TEEd" into the hose from the pump. I need to get round to putting a plastic valve in to stop the water going back out the pump at the moment I just clamp off the hose going back.
    If you get any small particles stuck in line you can back flush out the system. If you still want to do it your way ok. I would just want to run a brass valve since the plastic one can break.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: 07-09-2011, 04:45 PM
  2. Kawasaki ()) Stx Water Inlet
    By PeteSkeet in forum Kawasaki How To & FAQs
    Replies: 5
    Last Post: 08-05-2008, 06:35 AM
  3. test run after alloy inlet manifold
    By jetskibill9999 in forum 4-Tec Performance
    Replies: 7
    Last Post: 06-30-2008, 07:10 PM
  4. Water inlet filter
    By mboley in forum Polaris Open Discussion
    Replies: 22
    Last Post: 04-10-2007, 08:47 AM
  5. 2001 water bar/manifold.
    By wetherby in forum Polaris Open Discussion
    Replies: 30
    Last Post: 11-29-2006, 07:07 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •