Results 1 to 7 of 7
  1. #1
    2000 Polaris Pro 1200 rdizz81's Avatar
    Join Date
    May 2010
    Location
    Raleigh, NC
    Posts
    315

    2000 Polaris pro 1200 Issue no idea???

    Ok i went riding this morning it starting good and seem to do ok

    the first thing i noticed is that it just wasnt picking up like it used to and topped out at around 50mph this ski easily did 65+ then about 20mins into riding it i heard some clunking and it died i was dead in the water for about 2 mins it wouldnt turn over or anything... after 2 mins it turned over again and started but the engine would rev up but the ski really wouldnt move!..??? at this point it topped out around 20MPH...

    any ideas on this? so i put it on the trailer pulled it out and the engine will not turn over at all as if its seized which i dont see how that is possible?

    i just had it serviced tuned up. and BAM back in my garage with a tear in my eye... anyone have any ideas on what could have gone wrong i alomst felt like the impeller was not turning.


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,602
    +1
    1,277
    Remove the jet pump and drive shaft. Instructions are posted elsewhere on GH.

    Either the jet pump has seized, or the engine has seized.

    Once you have the jet pump off, check the impeller for smooth turning bearings.

    You can also take the spark plugs out, and try turning the engine over by hand using the PTO drive shaft coupler.

  3. #3
    2000 Polaris Pro 1200 rdizz81's Avatar
    Join Date
    May 2010
    Location
    Raleigh, NC
    Posts
    315
    If it is the jet pump is this a easy fix? it just seems od that the engine would seize... Last week 65+ running perfect this week get it serviced and tuned up lowered the Idle a bit and BAM broken jetski?... it really didnt run right from the get go? isnt part of a tune up to clean or service the jet pump?

  4. #4
    2000 Polaris Pro 1200 rdizz81's Avatar
    Join Date
    May 2010
    Location
    Raleigh, NC
    Posts
    315
    Also, Any idea where i may find the jetpump "how-To" i cant seem to find it in GH.

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,602
    +1
    1,277
    Quote Originally Posted by rdizz81 View Post
    ...Any idea where i may find the jet pump "how-To"

    I can't seem to find it in GH.
    Not sure how you are looking...

    Results of Search for jet pump removal ;

    How to remove the 148mm modular jet pump (1994-2004)

  6. #6
    2000 Polaris Pro 1200 rdizz81's Avatar
    Join Date
    May 2010
    Location
    Raleigh, NC
    Posts
    315
    Thanks K4 i did remove the Jetpump and it does seem to be seized now im stuck trying to find exactly what it is i need to fix it lol...

    i ordered a new impeller and not sure what else i need. i also broke a bolt off into the hull =( the long bolt that connects the jet pump.

    i think ima drop this thing offa cliff.

  7. #7
    austin157's Avatar
    Join Date
    Oct 2008
    Location
    Pickens SC
    Posts
    16
    +1
    1
    Theres a nice cliff next to my house,i can even help you lift it off the trailer!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2000 polaris pro 1200 no spark now no crank
    By lzboy308 in forum Polaris Tech Tips and Info
    Replies: 9
    Last Post: 06-11-2015, 06:20 PM
  2. 2000 polaris pro 1200 new cdi , no power, cdi
    By Joey_lobes in forum Polaris PWC Performance
    Replies: 2
    Last Post: 07-23-2014, 09:31 PM
  3. 2000 Polaris Pro 1200 Start issues?
    By rdizz81 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 05-07-2010, 10:51 AM
  4. 2000 Polaris Pro 1200 Race Ready
    By Tim Seebold in forum Polaris Classifieds
    Replies: 11
    Last Post: 11-30-2008, 02:07 AM
  5. 2000 Polaris Pro 1200
    By RollBama in forum Polaris Open Discussion
    Replies: 4
    Last Post: 08-25-2007, 02:02 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •