Results 1 to 6 of 6
  1. #1
    2000 Polaris Pro 1200 rdizz81's Avatar
    Join Date
    May 2010
    Location
    Raleigh, NC
    Posts
    315

    Jetpump/impeller question?

    If the jetpump or impeller is seized will you be able to turn the motor? with the sparkplugs out by hand?

    i assume no am i correct?


  2. #2
    Connecticut CrazyA's Avatar
    Join Date
    Nov 2005
    Location
    CT.
    Posts
    8,134
    +1
    1,050
    No, not if it's still connected to the impeller/pump and the pump is locked up.

    Have you at least climed under the ski while on the trailer and had a looksy up inside your pump tunnel?

    You may see something, you may not, but worth a quick look.

  3. #3
    2000 Polaris Pro 1200 rdizz81's Avatar
    Join Date
    May 2010
    Location
    Raleigh, NC
    Posts
    315
    so by knowing this now and help from my other post... i should remove the steering bolts and the 4 long bolts connected to the nozzle and remove the jet pump then try to turn the motor and this will tell me what i need to replace right? either jetpump or motor lol... =(

    if curious to see my symptoms check my other post from earlier today

    2000 Polaris pro 1200 Issue no idea???

    just trying to get back out there...



    ya i did look in to the impeller nothing that i saw that was my first thought as this morning i actually ran through a school of fish apparently and i had a few live ones jumping around my feet... GF was laughin on her working seadoo lol

  4. #4
    Connecticut CrazyA's Avatar
    Join Date
    Nov 2005
    Location
    CT.
    Posts
    8,134
    +1
    1,050
    That is correct. Steering and trim bolts, and the 4 long pump bolts. You need to disconnect the pump from the motor and then you'll know.

    The driveshaft has rubber bumpers on the ends, make sure to keep an eye out for those. They just press into the ends.

    Also, the watertube from the pump to the transom has an o-ring. Be careful not to damage or lose that.

    It's really a very simple procedure and I think you'll do fine.

  5. #5
    2000 Polaris Pro 1200 rdizz81's Avatar
    Join Date
    May 2010
    Location
    Raleigh, NC
    Posts
    315
    i got the pump removed and engine seems good but the pump is seized

    any ideas on what i need to fix? i was thinking of trying to just replace that whole unit is that possilbe?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Poalris jetpump.jpg 
Views:	39 
Size:	91.8 KB 
ID:	188462   Click image for larger version. 

Name:	jetpump2.jpg 
Views:	38 
Size:	72.9 KB 
ID:	188463  

  6. #6
    2000 Polaris Pro 1200 rdizz81's Avatar
    Join Date
    May 2010
    Location
    Raleigh, NC
    Posts
    315
    Also i forgot to mention one of the Long bolts that held the pump in place broke off... any suggestions on how to get that out...

    What a nightmare this is becoming.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXP impeller Question
    By The Bandit in forum 4-Tec Performance
    Replies: 9
    Last Post: 07-08-2007, 11:30 PM
  2. Guys with NEW RR SCer impeller. Questions!
    By Water4fire in forum 4-Tec Performance
    Replies: 17
    Last Post: 09-19-2006, 01:09 PM
  3. riva stage one and stage 2 impeller question
    By CarFanatic in forum 4-Tec Performance
    Replies: 6
    Last Post: 06-19-2006, 09:31 PM
  4. Impeller question
    By Flying Scotsman in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 02-04-2006, 08:12 PM
  5. Solas impeller question
    By Jeff C in forum 4-Tec Performance
    Replies: 6
    Last Post: 08-03-2005, 11:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •