Results 1 to 3 of 3
  1. #1
    em-dubya's Avatar
    Join Date
    May 2010
    Location
    Savannah, Ga
    Posts
    440
    +1
    7

    2000 Polaris Virage problem

    I purchased a 2000 Virage a couple months ago ,when i first tried it out it ran great, however the second time I took it out it kept wanting to stall when you gave it any throttle. I changed the spark plugs because they looked horrible and it started perfectly and did not stall at out out of the water. Today i took it out and it ran great for about 15 minutes then it started to stall again when a gave it any amount of throttle. I was about a mile from the marina and it would only run with the choke out (at idle speed) , if i attempted to push the choke back in it would cut off again...ANY ideas or suggestions of what it may be would be appreciated, before i have to call someone to loo at it.
    ...Oh yes when i got it out of the water to flush the cooling system it ran fine without shuting off and without the choke engaged


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,589
    +1
    1,273
    Welcome to the Hulk

    Lots to check, but start with cylinder compression.

    Also, make sure you are using the correct spark plugs for that engine.

  3. #3
    em-dubya's Avatar
    Join Date
    May 2010
    Location
    Savannah, Ga
    Posts
    440
    +1
    7
    Just an update here. I messed with it a few more times then i put it in the shop and had the carb rebuilt...5 weeks later its been running awesome and I've been having a blast with it

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2000 polaris virage tx resonator melted.
    By gnose in forum Polaris Open Discussion
    Replies: 10
    Last Post: 08-25-2017, 12:02 PM
  2. 2000 Polaris Virage 700 Exhaust Manifold Problems
    By AZRiverRat in forum Polaris Open Discussion
    Replies: 5
    Last Post: 06-27-2016, 05:04 PM
  3. 2000 Polaris Virage ignition problem
    By Stretchp2 in forum Polaris Open Discussion
    Replies: 8
    Last Post: 04-29-2015, 04:48 PM
  4. problems with starting 2000 polaris virage tx 1200
    By comet8871 in forum Polaris Open Discussion
    Replies: 7
    Last Post: 05-26-2012, 12:08 PM
  5. 2000 Polaris Virage TX Help!
    By paperbirch in forum Polaris Open Discussion
    Replies: 1
    Last Post: 08-27-2007, 12:12 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •