Results 1 to 10 of 10
  1. #1

    Results after mods...

    2007 Challenger 180SE
    X Model Supercharger
    42lb injectors
    4" intake
    Groco Strainer
    Modded stock waterbox
    09 RXP-X prop modified and pitched to 10/18
    SS wear ring

    82 degree water about same for air temp

    WOT - 48.5 mph at 7680 rpms with GPS

    approx 600 lbs riders and gear with 1/3 tank gas

    Assuming I don't add any more HP this year...what should I subtract from the prop to hit 8120?

    Thanks guys


  2. #2
    I would take at least 3 mm out of your prop but you will still likely be too tall. Why not add an external intercooler and rrfpr?

  3. #3
    Quote Originally Posted by cfnnslsq View Post
    I would take at least 3 mm out of your prop but you will still likely be too tall. Why not add an external intercooler and rrfpr?
    I think the wife has lost her tolerance for more mods at this point until next year.

    Thanks for your reply. I came across a how-to on oil change and from what I understand, having your oil level too high can cause loss of RPM as well.

    Dealer did my oil change, and the level is above the second hole in the stick. I am going to siphon some out and re-test to see if that makes a difference before re-pitching again.

  4. #4
    TheElite0ne's Avatar
    Join Date
    Jan 2009
    Location
    Tampa, FL
    Posts
    383
    +1
    20
    how was the hole shot? what did the RPM spike to?

  5. #5
    Quote Originally Posted by Jim-C180 View Post
    Dealer did my oil change, and the level is above the second hole in the stick. I am going to siphon some out and re-test to see if that makes a difference before re-pitching again.
    Curious to know the results after sucking some oil out. I also need to look into re-pitching here since I'm only hitting 7580-7600rpms.

  6. #6
    Quote Originally Posted by Guy on the water View Post
    Curious to know the results after sucking some oil out. I also need to look into re-pitching here since I'm only hitting 7580-7600rpms.

    I turned out to be roughly 3/4 quart high (DAMN DEALER)...will post after I test again...most likely not until the weekend.

  7. #7
    any news? i got an 07 challenger 180, im having a hard time getting good rpm's too... i got 4" cold air. x charger and injectors, riva rrfpr, external IC.. ive run a 14/19 4 blade, turns around 7400, a 13/19 skat 3 blade turns around 7250-7300, and a stock rxp prop @ about 7300.. the 4 blade will hit 8160 @ take off then drop, same for the 13/19, the stock rxp will hit 8250 then drop after a few seconds... i have swapped throttle body's, knock sensor, checked tank filter, looked for boost leak, checked compression, slip on the charger is set at 117 inch lbs, runs perfect just not enough rpm's.... i've built a few 90+mph rxp/gpr conversions no problem, this boat is killing me... am i still over propped? im in florida, so high humidity, air and water temps..any help would be great.. thanks mike b

  8. #8
    Quote Originally Posted by faster7581 View Post
    any news? i got an 07 challenger 180, im having a hard time getting good rpm's too... i got 4" cold air. x charger and injectors, riva rrfpr, external IC.. ive run a 14/19 4 blade, turns around 7400, a 13/19 skat 3 blade turns around 7250-7300, and a stock rxp prop @ about 7300.. the 4 blade will hit 8160 @ take off then drop, same for the 13/19, the stock rxp will hit 8250 then drop after a few seconds... i have swapped throttle body's, knock sensor, checked tank filter, looked for boost leak, checked compression, slip on the charger is set at 117 inch lbs, runs perfect just not enough rpm's.... i've built a few 90+mph rxp/gpr conversions no problem, this boat is killing me... am i still over propped? im in florida, so high humidity, air and water temps..any help would be great.. thanks mike b
    anyone got any clue?

  9. #9
    TheElite0ne's Avatar
    Join Date
    Jan 2009
    Location
    Tampa, FL
    Posts
    383
    +1
    20
    Quote Originally Posted by faster7581 View Post
    any news? i got an 07 challenger 180, im having a hard time getting good rpm's too... i got 4" cold air. x charger and injectors, riva rrfpr, external IC.. ive run a 14/19 4 blade, turns around 7400, a 13/19 skat 3 blade turns around 7250-7300, and a stock rxp prop @ about 7300.. the 4 blade will hit 8160 @ take off then drop, same for the 13/19, the stock rxp will hit 8250 then drop after a few seconds... i have swapped throttle body's, knock sensor, checked tank filter, looked for boost leak, checked compression, slip on the charger is set at 117 inch lbs, runs perfect just not enough rpm's.... i've built a few 90+mph rxp/gpr conversions no problem, this boat is killing me... am i still over propped? im in florida, so high humidity, air and water temps..any help would be great.. thanks mike b
    Thats everything I would of done.

    Can you try going back to the stock prop. With all the extra power over stock you should be all over the limiter on your stock prop. If you are then you probably just a pitching issue.... if you can't hit rev limiter on a stock prop with all that extra power then your losing power somewhere.

    Also, it wouldn't hurt to get an AFR reading just to make sure your RRFPR is dialed in.

  10. #10
    Quote Originally Posted by TheElite0ne View Post
    Thats everything I would of done.

    Can you try going back to the stock prop. With all the extra power over stock you should be all over the limiter on your stock prop. If you are then you probably just a pitching issue.... if you can't hit rev limiter on a stock prop with all that extra power then your losing power somewhere.

    Also, it wouldn't hurt to get an AFR reading just to make sure your RRFPR is dialed in.
    that was my next step is to find another stock prop and see what the rpm's are.. of course I cant find it.. i'll just hope someone here will give me a good deal.. thanks
    mike b

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Runs Sluggish after mods !!!!
    By wavehummer in forum 4-Tec Performance
    Replies: 22
    Last Post: 06-06-2007, 09:15 PM
  2. Replies: 3
    Last Post: 05-29-2007, 02:06 PM
  3. GPS'd my '03 after mods seems a little slow any ideas?
    By NateGP1300R in forum Yamaha PWC Performance (2-stroke)
    Replies: 21
    Last Post: 07-06-2006, 07:15 AM
  4. '03 1300R slower after mods, ideas?
    By NateGP1300R in forum Yamaha PWC Performance (2-stroke)
    Replies: 13
    Last Post: 06-05-2006, 10:08 PM
  5. a few results after modifications
    By watermedic in forum 4-Tec Performance
    Replies: 10
    Last Post: 04-26-2006, 07:50 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •