Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 21
  1. #1

    Join Date
    May 2010
    Location
    San Jose CA
    Posts
    10

    New here...Need help on my 2008 RXT 255 Seadoo

    Hi guys

    Im new here, Im hoping one of you can lend a hand........

    I have a 2008 RXT 255. I've had it for 11 months now.

    I'm pinned right around 70 MPH or what ever the tack and speedo max's out at.

    Last week we went ridding...( we go 2-4 times a week. )

    Anyway. I was rolling at 70 for a few hours. Then all of a sudden I lost 5-7
    MPH? Now the ski runs fine..no smoke, clacking noise etc. I ran some sea
    foam in it..new fresh high octane gas. No change.

    Before the power was down it ran 70 MPH at 8000 RPMs. I would go into a
    turn at 70 and the speed would maybe drop to 66-67 at the most.

    Now I go into a turn and it drops to 55-57?? And the RPM's wont go higher than 7850.

    Top speed 64-67 and that's a maybe.

    I took it to the dealership. They ran a few tests. Compression was fine.
    They said they did some type of test on the super charger where they hold
    the hose in and rev the throttle? Then if the hose flex's out it's fine?

    The said the impeller was good and the pump was good also. It's under
    warranty until next month and I do plan on getting the extended warranty at that time.



    Can anyone suggest anything that might cause this problem??


    Thanks for any help


    Rick
    Last edited by Ricksraiders; 05-16-2010 at 03:33 PM. Reason: wrong wording


  2. #2
    Marine speedo is usually 3~5mph off (showing faster than actual) GPS (or Radar) is only true speed indicator...

    First, check that the OPAS Blades are fully retracted at top speed and that the plumbing isn't clogged w/ sand/mud. If they drag in the down position it'll scrub a lot of speed.

    Sorta sounds like the Supercharger Ceramic Clutch Washer failure issue w/ earlier Models but since the '08's are supposed to have metal Clutch Washers that must not be the issue. I would have the dealer lock up the Cam/Crank and do a Torque test on the Supercharger Clutch slippage just the same. This can be done with the S/C still installed with the proper tools which the dealer should have.

    Then.... check Fuel Pressure and Volume. If the unit has more than 80hrs. replace the Fuel Filter on the bottom of the Fuel Module.

    If it starts and idles well then [3] Ignitors (Coils) should be working well but a faulty Voltage Regulator/Rectifier cant be ruled out w/o a test to be sure.

    ---DvD

  3. #3

    Join Date
    May 2010
    Location
    San Jose CA
    Posts
    10
    Thanks for the help!!!! I'll bring this up Monday at the dealer.

  4. #4
    YoYamma's Avatar
    Join Date
    Aug 2006
    Location
    Central Florida
    Posts
    21,528
    +1
    4,754
    Ricksraiders, be advised; as I recall, at some point you are REQUIRED to replace your supercharger on that 08 model in order to keep your warranty active, this new policy started in 2008 - read your owner's manual carefully and you will see it. I believe it is at the 100 hour mark, so talk this over with your dealer.

  5. #5
    maybe dont run it WOT @70mph for hours on end...


  6. #6
    Big K's son KeithKman's Avatar
    Join Date
    Dec 2006
    Location
    Southern California
    Posts
    1,735
    Sounds like a boost leak and/or the SC slip is off. How many hours are on the ski?

  7. #7

    Join Date
    May 2010
    Location
    San Jose CA
    Posts
    10
    Ive got 51 hours on it in one season..

  8. #8
    mrbtd's Avatar
    Join Date
    Jul 2005
    Location
    Lindenhurst, Illinois, United States
    Posts
    4,309
    +1
    2
    Quote Originally Posted by OJX View Post
    maybe dont run it WOT @70mph for hours on end...

    Why not ? If all other parts are working 100% it is designed for that abuse.

  9. #9

    Join Date
    May 2010
    Location
    San Jose CA
    Posts
    10
    Quote Originally Posted by OJX View Post
    maybe dont run it WOT @70mph for hours on end...





    Wow really man??? That's the same thing my girl friend said??

    She's scared to go past 50?? You have that same issue???

    Thanks for that help man!!


    You ever think this? If your Aunt had a *ick she'd be your uncle!!!











    ( Sorry guys...I just couldn't resist )

  10. #10
    mrbtd's Avatar
    Join Date
    Jul 2005
    Location
    Lindenhurst, Illinois, United States
    Posts
    4,309
    +1
    2
    I agree with David..Look @ the fins in back of the ski. Do they move up and down freely ?

    If they do not then they act as an anchor. The extra drag is lowering the RPM's.


    We are guessing it spools right up to the 7800 like it used to ?

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need help on my new 95 Polaris SLX 780
    By napz22 in forum Polaris Open Discussion
    Replies: 17
    Last Post: 02-28-2011, 12:45 PM
  2. i need help on my gprxp
    By raul466 in forum Conversion PWC Performance Skis
    Replies: 1
    Last Post: 07-23-2009, 08:38 AM
  3. New here, need help with 1200 XLT
    By tnerb in forum Yamaha Open Discussion
    Replies: 18
    Last Post: 05-13-2009, 12:15 AM
  4. need help on my 550sx - 650sx conversion!!
    By PeteSkeet in forum Conversion FAQ and Tips
    Replies: 0
    Last Post: 05-01-2009, 09:36 PM
  5. New and need help diagnosing my '08 rxtx
    By dr_hunt in forum 4-Tec Performance
    Replies: 50
    Last Post: 06-28-2008, 06:16 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •