Results 1 to 3 of 3
  1. #1

    Had a problem getting gas

    I had a problem getting gas to pump in my 1995 650sl so I upgraded to a triple pump and when I removed the pulse line from the engine block water streamed out, Im guessing thats bad or is it normal?

  2. #2
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Cleveland OH
    Good and bad.

    Bad that is was in there, but good that you removed it.

    Liquid in the pulse hose will damage the diaphragm or not allow it to work at all.

    Good find.

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    near Toronto, Canada
    Quote Originally Posted by keader07 View Post
    ...removed the pulse line from the engine block water streamed out...
    How long was the water in there?

    Rusted crank bearings are a bad thing.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Race Gas / Pump Gas Mixing Chart
    By ABBOTT in forum Yamaha How To & FAQs
    Replies: 5
    Last Post: 02-23-2012, 05:47 PM
  2. Gas gauge problem?
    By seadooingfreak in forum 4-Tec Performance
    Replies: 4
    Last Post: 04-21-2008, 06:04 AM
  3. 07 Kawi 250x gas in oil problem
    By barmy army in forum Kawasaki PWC Performance (4-stroke)
    Replies: 2
    Last Post: 02-04-2008, 07:47 PM
  4. Gas gauge problem!
    By dcs191919 in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 09-05-2007, 07:45 AM
  5. Seadoo rear gas can mount (Save on lake gas prices!!)
    By Kinchyle in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 09-01-2005, 01:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts