Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1
    skigolfnut's Avatar
    Join Date
    Jun 2009
    Location
    League City TX
    Posts
    1,979
    +1
    33

    Need more rpm's for stock pro-785

    I had my bone stock 97 Pro785 out yesterday, It ran good, fast acceleration, good hole shot, but it would only top out at 7200-7400 rpm's
    my piston wash looked good not to lean but good, I checked the throttle pull wire and it is opening the carbs up all the way, any suggestion on getting more rpm's?


  2. #2
    bowsniper's Avatar
    Join Date
    Aug 2008
    Location
    macomb,michigan
    Posts
    5,896
    +1
    6
    Did you run the ski thru the tuning tips on here? I dont know the procedure right off hand. its a series of runs changing the high settings till you get your highest RPM, A member can chime in on this one..

    or your impellor is chipped,too much clearence in the wear ring, or chipped stator blades, or air getting in the pump area. everything sealed up down there perfect? ripdeplate, grate, pump shoe/? if the coupler bearing is going, it can seep air there too. should be tight to the seals.

    or the wrong pitch impellor.. what kind and pitch are you running? stock 12/17?

    Plug condition?

    wires cut back a 1/4 inch? maybe loosing a little spark transfer at the plug wire

    just a few ideas to kick around..

    even bad bearings in the pump will slow ya down. too much resistance or out of alignment could cause loss of speed because of friction/or binding.

  3. #3
    skigolfnut's Avatar
    Join Date
    Jun 2009
    Location
    League City TX
    Posts
    1,979
    +1
    33
    I saw Randy's tuning tips for girls and have been looking at my wash and the wash seems fine, no hesitation on the hole shot, jets are set to the factory stock position, stator and propellor have no chips, shaft no wobble, looks pristine all the way around??
    Kind of stumped,

  4. #4
    bowsniper's Avatar
    Join Date
    Aug 2008
    Location
    macomb,michigan
    Posts
    5,896
    +1
    6
    Hmmm.

  5. #5
    100 MILES OF HEAVEN AND I AM SMACK IN THE MIDDLE KEYZBUM's Avatar
    Join Date
    Apr 2007
    Location
    JUST NORTH OF CUBA-- FL,KEYS
    Posts
    2,556
    +1
    39
    Quote Originally Posted by skigolfnut View Post
    I had my bone stock 97 Pro785 out yesterday, It ran good, fast acceleration, good hole shot, but it would only top out at 7200-7400 rpm's
    my piston wash looked good not to lean but good, I checked the throttle pull wire and it is opening the carbs up all the way, any suggestion on getting more rpm's?
    rpm's on the mfd or pet tack???

  6. #6
    skigolfnut's Avatar
    Join Date
    Jun 2009
    Location
    League City TX
    Posts
    1,979
    +1
    33
    the RPM's are on the MFD,

  7. #7
    100 MILES OF HEAVEN AND I AM SMACK IN THE MIDDLE KEYZBUM's Avatar
    Join Date
    Apr 2007
    Location
    JUST NORTH OF CUBA-- FL,KEYS
    Posts
    2,556
    +1
    39
    Quote Originally Posted by skigolfnut View Post
    the RPM's are on the MFD,
    DING DING--time for a real tach
    i have had 1 out of 10 mfd's read the same as my pet tach(and oddly that mfd was saying i was pushing 19 volts but testing with meter it wasnt,but it was within 10 rpm's of the pet tach so go figure !!!!!!!!!
    matt

  8. #8
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,569
    +1
    1,272
    Quote Originally Posted by KEYZBUM View Post
    ...I have had 1 out of 10 mfd's read the same as my PET tach...
    How different are the RPM readings between MFD and PET tachometers?

    These all or mostly Fuji motors?

  9. #9
    I couldnt see the RPMs being off TOO much on a MFD. But the one on my SLT780 does read 15-16V normally, which is nowhere near what it really is...

  10. #10

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,702
    +1
    109
    i've seen the factory tachs go bad before ,i would also see what impeller is in there

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB in need of a magneto for a pro 785 all years i belive
    By wayneb2510 in forum Polaris Classifieds
    Replies: 4
    Last Post: 07-20-2013, 11:01 AM
  2. Normal RPM's for Stock GTX 155
    By drb in forum 4-Tec Performance
    Replies: 4
    Last Post: 06-15-2009, 12:22 PM
  3. need help for tuning pro 785
    By pro145hp in forum Polaris PWC Performance
    Replies: 7
    Last Post: 04-07-2007, 05:13 PM
  4. **merged from original thread** need more rpm's
    By TILERYBOY2 in forum Yamaha PWC Performance (2-stroke)
    Replies: 136
    Last Post: 10-07-2006, 04:43 PM
  5. need more rpm's
    By TILERYBOY2 in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 10-04-2006, 09:27 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •