Results 1 to 10 of 10
  1. #1

    Join Date
    May 2010
    Location
    LONG ISLAND
    Posts
    31

    Question My new ski ...breakin ..concerns

    i now have a new stx 15f.. i took it pretty easy 5k or under on rpms...only was able to drive for a total of an hour but when i went back to the ramp to pack it in it would not start??? any ideas already posted in performance section...other thing is what should i do for my next ride and was my first ride keeping it under 5k a good start for the ski since the manual says under 3/4 throttle


  2. #2
    mirror's Avatar
    Join Date
    Jan 2006
    Location
    Seminole, FL
    Posts
    532
    +1
    3
    I assume you did finally get it to start since you are talking next ride. Do you know why it wouldn't start. I am breaking in my 2nd 15f and I just do 10 hours of riding with cruising around 40 and under with a few fast bursts, changing speeds often and just enjoying cruising type rides. After that just follow the manual for service. It would help to know what it was doing when it wouldn't start.

  3. #3

    Join Date
    May 2010
    Location
    LONG ISLAND
    Posts
    31
    yea i eventually got it to start once i brought it home and let it sit but when it wasnt starting it just kept cranking and sounded heavy could it just have been flooded?

  4. #4
    Daveski's Avatar
    Join Date
    Apr 2009
    Location
    Franklin,WI
    Posts
    488
    Mine did the same thing once, Im guessing it was vapor lock in the fuel line, once it cooled down it started right up

  5. #5

    Join Date
    May 2010
    Location
    LONG ISLAND
    Posts
    31
    o yea and i opened the gas cap when before i started i totally forgot about that! so hopefully thats all it was i dont wanna get stuck on the water...or ill have to make a sad call to the main vessel (formula 31pc) lol

  6. #6
    Texan78's Avatar
    Join Date
    Feb 2010
    Location
    N. Texas
    Posts
    395
    Did it sound like the battery may have been weak? Did you rebuild the carbs?

  7. #7

    Join Date
    May 2010
    Location
    LONG ISLAND
    Posts
    31
    no the battery was strong i had just come in

  8. #8
    mirror's Avatar
    Join Date
    Jan 2006
    Location
    Seminole, FL
    Posts
    532
    +1
    3
    There are a few threads on here about the 15f having starting issue when hot. I have had it happen to mine a few times, it just cranks and doesn't even try to fire. I also was with a friend with her '04 and it did the same thing. Some people claim to know what it is such as a sensor but I just let mine sit and then it starts when it is ready. Kind of a pain but better than leaving it at the dealer while they take weeks trying to determine what they don't know.

  9. #9
    baba booey's Avatar
    Join Date
    Apr 2007
    Location
    San Diego
    Posts
    526
    Quote Originally Posted by Texan78 View Post
    Did it sound like the battery may have been weak? Did you rebuild the carbs?
    FYI, 15f's are fuel injected.

  10. #10

    Join Date
    May 2010
    Location
    LONG ISLAND
    Posts
    31
    that sucks im just never gonna turn it off ever again that should fix the problem

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New Look for my New Ski
    By sixtydashone in forum Kawasaki Projects
    Replies: 27
    Last Post: 08-18-2008, 09:12 PM
  2. My New Ski
    By big raider in forum Yamaha Old School Skis
    Replies: 28
    Last Post: 07-21-2008, 10:04 PM
  3. My new ski with no exhaust
    By JFizzleJR in forum 4-Tec Performance
    Replies: 31
    Last Post: 06-20-2008, 09:27 PM
  4. my new ski
    By levonhelmet in forum Sea Doo Open Discussion
    Replies: 12
    Last Post: 05-13-2008, 09:55 PM
  5. My new ski
    By christian gpr in forum Yamaha Open Discussion
    Replies: 8
    Last Post: 06-22-2006, 09:10 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •