Page 1 of 8 1 2 3 ... LastLast
Results 1 to 10 of 79

Thread: RPM's MISSING?

  1. #1
    enforcer's Avatar
    Join Date
    Mar 2006
    Location
    San Antonio, Tx.
    Posts
    686
    +1
    22

    RPM's MISSING?

    Wanted to see if anyone else would shed some light. I purchased a used Riva ECU and 50 lbs. injectors from WFO. the other mods that I have are as follows: Les Cooke retainers, X-charger, X-S intercooler with bleed mod,15-20 4blade solas, grocco strainer, free flow exhaust. My question is that I took it to the dealer and had the buds connected and reset the throttle to zero and also programmed the practice key as well. took it out this past weekend and all it did was 74.4 @8100 rpm's...... I have the blow off valve blocked off and can't seem to find a boost leak as I rechecked everything and it is all sealed up good. for some reason I'm not seeing 8400 rpm's + or even 8500........ Water4fire has a similar set-up and is doing 83+ in the same condition with the exception of a ride plate and open loop cooling. this is sort of frustrating because i have followed instructions to the "T" ....I'm now wondering if the knock sensor update has anything to do with it as this is a 2004. Funny thing though because before I did these mods I was still hitting 8100 RPM'S with a stock boat and prop, so I'm thinking it doesn't have to do with this sensor update?
    I'm not certain , however if some one is familiar with this set-up please let me know as this is baffling.


  2. #2
    dhoad's Avatar
    Join Date
    Aug 2005
    Location
    North Aurora, Illinois, United States
    Posts
    3,182
    +1
    6
    does the ECU have a riva sticker on it?
    what boost are you seeing?
    have you checked SC slip?
    definitely check for the knock sensor update in the wiring harness

  3. #3
    enforcer's Avatar
    Join Date
    Mar 2006
    Location
    San Antonio, Tx.
    Posts
    686
    +1
    22
    [QUOTE=dhoad;1432155]does the ECU have a riva sticker on it?yes
    what boost are you seeing? I don't have a boost guage on it yet
    have you checked SC slip? No it only has 5 hrs. on it I Bought it new.
    definitely check for the knock sensor update in the wiring harness Will do

  4. #4
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77

    Re: RPM's MISSING?

    Normally you have to have your prop tweaked after an aftermarket ecu change bro. its probably that simple.

  5. #5
    Vern's Avatar
    Join Date
    May 2005
    Location
    Grand Haven, MI
    Posts
    3,594
    +1
    128
    Quote Originally Posted by Ocman View Post
    Normally you have to have your prop tweaked after an aftermarket ecu change bro. its probably that simple.
    Exactly ... if your prop was keeping you at 8100 rpms max with the stock ECU, adding the Riva ECU will not add much hp at 8100 rpm, so most people need to pull back the impeller a couple mm on the trailing edge to let the rpms come up. Mess with impeller and or nozzle rings to get rpms to 8500 and your speed will come up.

  6. #6
    masta2000's Avatar
    Join Date
    Aug 2009
    Location
    montreal-quebec
    Posts
    576
    +1
    1
    i disagree, the only difference between a stage 3 kit without ecu and with ecu is the injectors. s3 with stock ecu and #42 = 75mph, s3 with riva ecu and #50 = 80+.
    the ecu makes a huge difference and the prop stays the same.
    i just added rr ecu and the rpm came up 400rpm. no tweaking of the prop necessary. i believe the stock ecu has way less aggressive timing curve and really cuts out around the stock rev limit

  7. #7
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77

    Re: RPM's MISSING?

    Quote Originally Posted by masta2000 View Post
    i disagree, the only difference between a stage 3 kit without ecu and with ecu is the injectors. s3 with stock ecu and #42 = 75mph, s3 with riva ecu and #50 = 80+.
    the ecu makes a huge difference and the prop stays the same.
    i just added rr ecu and the rpm came up 400rpm. no tweaking of the prop necessary. i believe the stock ecu has way less aggressive timing curve and really cuts out around the stock rev limit
    On my change last week I noticed about a 200 rpm increase to 8320 but I was on the limiter. This would not be the norm I suspect.

  8. #8

    Join Date
    May 2007
    Location
    Germany
    Posts
    19
    check the fuel pressure when ski running. must 4 bar.

  9. #9
    enforcer's Avatar
    Join Date
    Mar 2006
    Location
    San Antonio, Tx.
    Posts
    686
    +1
    22
    Quote Originally Posted by masta2000 View Post
    i disagree, the only difference between a stage 3 kit without ecu and with ecu is the injectors. s3 with stock ecu and #42 = 75mph, s3 with riva ecu and #50 = 80+.
    the ecu makes a huge difference and the prop stays the same.
    i just added rr ecu and the rpm came up 400rpm. no tweaking of the prop necessary. i believe the stock ecu has way less aggressive timing curve and really cuts out around the stock rev limit
    I agree It must be a boost leak, or the ecu is not working properly.I was told by many people who have similar set ups that this should be a strong 79+ mph boat.........I have all ready disassembled my boat as I typed and I didn't see any loose connections. I will check the block off plate and intake manifold to see if there is a possible leak there.The RPM's should be around the 8500 mark from what I gather or even closer to the 8600 range.

  10. #10
    Richieb's Avatar
    Join Date
    Oct 2008
    Location
    Sydney, Australia.
    Posts
    1,001
    You have to remember there is speed in the hull too.

    You have gone quite up on the impeller(prop) too.

    The thing, or trick is the pump nozzle pressure is where it all comes from as far as the ski being pushed along the water.

    Maybe the orig numbers were in the 65-67 mark, and you have gained 8-ish MPH, which is respectable.

    Sounds like the pump is loaded up to hold it down to 8100 though. Can you put a 14/19 in there to see if the RPM rises at all?

Page 1 of 8 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Honda F-15 Stage 2 RPM s missing
    By Oberststubinski in forum Honda Performance
    Replies: 4
    Last Post: 02-12-2012, 07:55 AM
  2. Missing RPM's?
    By ARNYGOLLOTT3 in forum 4-Tec Performance
    Replies: 12
    Last Post: 06-30-2007, 01:41 PM
  3. Replies: 25
    Last Post: 04-17-2007, 10:13 AM
  4. Found my missing RPM`S 74mph plus now
    By CRS in forum 4-Tec Performance
    Replies: 19
    Last Post: 05-29-2006, 03:42 PM
  5. Missing RPM???
    By TxTele in forum Yamaha PWC Performance (2-stroke)
    Replies: 10
    Last Post: 04-18-2006, 10:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •