Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1

    Join Date
    Apr 2010
    Location
    Michigan
    Posts
    194

    Please help with a 2000 Polaris SLH project with issues

    I picked up a 2000 Polaris SLH dirt cheap and it comes with issues. The owner did not know much about it because her husband took care of it. It was stored the last year outside, but before that it was garaged. I have not done much yet. I did turn the crank over a little bit. The fuel tank is full to the top with fuel and the fuel switch is in the off position.
    The bad part....
    There is oil everywhere in the hull. I am not sure where it came from but it appeared to be dripping from the exhaust after the water box. (There looks to be two hose barb fitttings with nothing attached to them.)
    There are water condensation on the inside of the read-out and there was no power to the MFD when I powered the battery cables. The trim button did nothing and the bilge pump did nothing when i pushed those buttons. The start button did turn over the ski. The circuit breaker was not tripped. I only let it turn over a few times. ( I did not want to get bad fuel in the carb if if it had been properly winterized) The ski sat two seasons, but I was told it was in running condition when it was stored.
    ALSO, the hull has a pretty rough bottom with two thin spots and the oil from inside the hull is leaking through. It almost looks like it came off the trailer and got dragged down the street

    My plan is to drain the fuel and wash the hull out and try and start it with fresh fuel. I can then get compression numbers. Will the ski start without the MFD? What might cause no power to the MFD? What would cause all the oil everywhere? Any help or suggestions would be much appreciated. Thanks in advance....


  2. #2
    ryandi2's Avatar
    Join Date
    Aug 2009
    Location
    conesus ny!
    Posts
    2,092
    +1
    19
    check all oil lines! take carbs of and clean them empty the gas tank and put fresh gas in.. re place all lines..

    you shouldnt have an issue with starting it with out the mfd working..


    what do you mean thin spots in the hull? post pictures of the ski...

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,593
    +1
    1,275
    Don't be in a hurry to start the engine. Check other things first.

    First thing is to check compression.

    Take all the spark plugs out, and crank it over. Leave the fuel selector turned off.

    If oil comes spewing out the spark plug holes, clean it up, and see if it keeps coming. Don't crank for more than about 15 seconds at at time, so you don't overheat the starter motor.

    If water comes out of the spark plug holes, or a milky mixture (water+oil), then the engine has rusted inside, and will need a complete rebuild.

    No liquids coming out - check compression.
    All spark plugs out, throttle held wide open.

    Each cylinder should be within 5% of the others.

    Tilt the nose of the trailer up as high as you can, and drain the oil out the drain holes at the back of the hull. Then mop up the remaining puddles inside.

    There is no oil normally inside the exhaust system. Sometimes an oil combustion residue mixed with water, but not a large quantity of oil.

    Is the oil tank still in place? Does it contain oil?

    The MFD display is junk, if it has water inside. You can unplug the connector from the back side, and the engien will run (if everything else is OK).

    Without a working MFD, you will not see any warnings, like engine overheat.

    If the engine still has the original gray Tempo brand fuel lines, they need to be replaced. Replace the fuel filter too. Those gray hoses also mean the tiny carburetor internal filters may be clogged, so plan on doing a carb rebuild.

    Do you have the ability to repair the hull damage?

  4. #4

    Join Date
    Apr 2010
    Location
    Michigan
    Posts
    194
    I will get the compression numbers tomorrow as well as check the cylinders. I can repair the hull with two part expoxy right? The bottom is pretty rough, but there two round spots about the size of a quarter that are through to the fiber and the oil inside the hull can be seen. Is there a roll on coating that I could re-seal and
    re- finish the bottom of the hull.
    I will post pictures soon.

  5. #5

    Join Date
    Apr 2010
    Location
    Michigan
    Posts
    194
    Do you know of a good hull epoxy in white that I can use to redo the bottom of my hull? Thanks.

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,593
    +1
    1,275
    Quote Originally Posted by dalepatter View Post
    Do you know of a good hull epoxy in white that I can use to redo the bottom of my hull? Thanks.
    Have a look at this thread, for starters;

    Painting a jetski

  7. #7

    Join Date
    Apr 2010
    Location
    Michigan
    Posts
    194
    It looks like when I turned over the engine fogging oil was spitting out. It had 130 psi in each cylinder but no spark. Oil tank was at 3/4. I pulled the MFD and had 12 volts between the red and black wire.
    As a side note it does have the gray Tempo fuel lines.

  8. #8

    Join Date
    Apr 2010
    Location
    Michigan
    Posts
    194
    What do I need to check to get spark?

  9. #9
    Quote Originally Posted by dalepatter View Post
    What do I need to check to get spark?

    Battery voltage while cranking.

  10. #10

    Join Date
    Apr 2010
    Location
    Michigan
    Posts
    194
    Battery Voltage is good. What else is on the suspect list?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Please help with impeller selection for our project
    By toplevel in forum Sea Doo Build Threads
    Replies: 11
    Last Post: 03-20-2013, 11:40 AM
  2. Please help with my 2002 Polaris Virage TXi check engine code
    By Dan416 in forum Polaris Open Discussion
    Replies: 3
    Last Post: 08-25-2011, 05:08 PM
  3. Please Help with 1999 Polaris Genesis carbureted ski.
    By K-9 in forum Polaris How To & FAQs
    Replies: 15
    Last Post: 05-09-2010, 01:49 PM
  4. Please help with 2000 slx
    By ruusty in forum Polaris Open Discussion
    Replies: 4
    Last Post: 07-29-2009, 02:25 PM
  5. Please help with 1997 gp1200
    By grumpeeau in forum Yamaha Old School Skis
    Replies: 15
    Last Post: 03-08-2007, 09:57 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •