Results 1 to 3 of 3
  1. #1

    94 SL 750 leak..

    I start up my 750 and a mixture of unburned fuel and oil drips out of the back. This is a new issue... (developed in the last hour or so), and I do a pre-mix (removed oil pump) - if that helps.

    Any suggestions would be appreciated.

    Thanks!


  2. #2
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,328
    +1
    29
    Was the petcock left on? (main or reserve)

    What happens when you remove the spark plugs and press the start button? Does gas come shooting out?

    Are the carbs dripping fuel when running? (need to remove Fa and look down carb throats when running)

  3. #3
    The petcock had been left on (main), and without plugs no gas comes out.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 94 SL 750 IDLE rpm 1900
    By quad2water in forum Polaris How To & FAQs
    Replies: 9
    Last Post: 06-28-2007, 04:11 PM
  2. '94 SL 750 Fuel Problem
    By rob2337 in forum Polaris Open Discussion
    Replies: 13
    Last Post: 06-24-2007, 07:10 PM
  3. 94 SL 750 and 97 SLT780
    By quad2water in forum Polaris Open Discussion
    Replies: 2
    Last Post: 06-19-2007, 12:41 AM
  4. 94 SL 750 just purchased what should i check?
    By GameDemon in forum Polaris Open Discussion
    Replies: 5
    Last Post: 06-19-2007, 12:01 AM
  5. 94 sl 750 maintenance anyone?
    By ducatifreak152 in forum Polaris PWC Performance
    Replies: 4
    Last Post: 06-09-2007, 03:07 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •