Results 1 to 7 of 7
  1. #1

    newbie.. polaris acceleration problem

    im new to this site, please dont bash me for posting in the wrong section..sorry in advance. Question is why is it that my slt 750 takes forever to get up on plane. I have to feather the throttle to gradually get it going. once it gets up its out like a fat kid in dodge ball. I have the problem in both smooth water and chop. just picked up a r&d intake grate in hope that it will fix this. I also checke impeller and clearence.....looks good. Please help me i know there are experts on here that can anwser my qustion.


  2. #2
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    WELCOME to the Green Hulk Forums.

    You may be running lean, you may have a dead cylinder.
    Check compression so you can verify you don't have a hurt engine.
    In the tech section under Fuji engines you'll find information regarding the fuel supply issues and what it may take to cure your problem.
    I'd start with checking the fuel pressure in your system to verify if you have a fuel issue.
    Roughly 2 pounds at idle, 4 at WOT. Make your WOT VERY short as you are in danger of ruining your engine if it's a lean running condition.

    You need to check the pressure anywhere between the fuel pump and the fuel restrictor(s).

  3. #3
    do u think a triple outlet fuel pump will fix this problem

  4. #4
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    More than likely but you need to know if the motor is O.K. check the compression real quick.
    Remember to replace the fuel valve and all the hoses (including the pulse line) while you're updating the fuel system.

  5. #5
    thank you for the good info and the direction. is there anyway you may have a schematic on the fuel pump. I know where the return line, the main feed and the three carb feed lines go but which one is the pulse line?

  6. #6
    blegan's Avatar
    Join Date
    May 2008
    Location
    bakersfield
    Posts
    321
    Quote Originally Posted by xtremepete View Post
    thank you for the good info and the direction. is there anyway you may have a schematic on the fuel pump. I know where the return line, the main feed and the three carb feed lines go but which one is the pulse line?
    Pulse line nipple is right below the intake manifold @ p.t.o. location.

  7. #7

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 4
    Last Post: 07-01-2015, 07:34 AM
  2. Polaris Virage Acceleration problems
    By farley in forum Polaris Open Discussion
    Replies: 1
    Last Post: 05-01-2014, 03:18 PM
  3. 2001 gp1200r acceleration problem??
    By 2000mustangMia in forum Yamaha Open Discussion
    Replies: 18
    Last Post: 04-13-2012, 02:08 PM
  4. Polaris SLTH Problem!
    By smoke20 in forum Polaris PWC Performance
    Replies: 5
    Last Post: 07-19-2007, 01:30 PM
  5. 96 polaris sl700 problems
    By markamus in forum Polaris Open Discussion
    Replies: 31
    Last Post: 05-27-2007, 03:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •