Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
  1. #1
    2000 Polaris Pro 1200 rdizz81's Avatar
    Join Date
    May 2010
    Location
    Raleigh, NC
    Posts
    315

    jet pump impeller Question pic included

    Ok so got the new stator fully assembled THANKS SIRHC and the new impeller and impeller tool now what goes where... lol

    just wanna make sure i put it together correctly

    there is a small round metal bearing type peice a small rubber gromit

    the impeller, stator and impeller tool
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	statorimp.jpg 
Views:	140 
Size:	110.8 KB 
ID:	189469  


  2. #2

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,704
    +1
    109
    the stainless spacer goes onto the shaft and into the seals in the front put alittle grease on it before slipping it on .
    Grease on the outside of it .

    What prop is that ??? a Solas

  3. #3
    bowsniper's Avatar
    Join Date
    Aug 2008
    Location
    macomb,michigan
    Posts
    5,896
    +1
    6
    Heres how I did mine.. what are you making sure of if the pump is together? just that 1 piece? I

    Pull out the stub shaft out of the stator first. set aside.

    Pry out large seals on both ends to expose bearingsRemove large o-ring on inner ID. youll see it

    Use a flat head screwdriver (large) and slide the head of the driver down inside the bearing (you will see a aluminum spacer inbetween the bearsings) so as to get the edge of the screwdriver on the other bearing wall. tap with hammer all around bearing, it will fall out.

    of course the aluminum tube inside there will come out now

    Turn over and do the same routine for other bearing

    make sure you take out each sides large ends seals or else the second wont come out!

    now it should be empty. unless i missed something..lol


    to put in. Heat stator in over with NO O--RINGS IN IT. about 200-250 for 10 mins till its hot. meanwhile freeze the bearings in the freezer. 15 mins

    You will have 10 seconds or so. they will fall in easily. MAKE SURE U PUT THAT ALUMINUM PIECE IN BEFORE YOU PLACE THE LAST BEARING IN!!!!! or else you may do it wrong and have to pound the NEW bearing out, which you dont want to do,

    after bearings are in, cool off the stator and instasl LARGE o-ring and the seals. push seals in evenly and make sure the bearings are fully seated on both ends.

    install stub shaft into pump again, grease that spacer like lugs said and the seal. your done!

    Guys if I made any mistakes. correct me. I think I have it right. just check me..!!! Thanks Looks like he drinks budlight too! (were polaris detectives), we notice EVERYTHING!

    The impellor just screws on and its torqued to specs.. Use your new tool! Put the stub shaft in the vise when torquing. becareful not to mess up the stub shaft end in the vise.. Then your good to go.

    Just a thought,, when putting the prop on be very careful, they are super sharp when new. and when its in the vise be careful not to try to save it if it falls out of the vise with the impellor on, that thing will weigh 10lbs finished and if it that blades touches you as you try to grab it, it could really hurt you.

  4. #4

    Join Date
    Sep 2009
    Location
    Denver,NC
    Posts
    93
    Let it sit to cool off naturally. Don't use water or put it in the fridge. This is from years of Porsche transmission work.

  5. #5
    2000 Polaris Pro 1200 rdizz81's Avatar
    Join Date
    May 2010
    Location
    Raleigh, NC
    Posts
    315
    Yes it is a Solas prop! =)

    also the pump is put together and spining good!

    Ok so Grease the Spacer slip onto the stubshaft pull on stubshaft and put a vice on it to keep from spining..

    attach the impeller with new tool and tourqe wrench to spec..

    what about that rubber grommit? where does that go it came with the impeller

  6. #6

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,704
    +1
    109
    Quote Originally Posted by rdizz81 View Post
    Yes it is a Solas prop! =)

    also the pump is put together and spining good!

    Ok so Grease the Spacer slip onto the stubshaft pull on stubshaft and put a vice on it to keep from spining..

    attach the impeller with new tool and tourqe wrench to spec..

    what about that rubber grommit? where does that go it came with the impeller
    what # solas ???

    in the front of the prop where the shaft slips through

  7. #7
    bowsniper's Avatar
    Join Date
    Aug 2008
    Location
    macomb,michigan
    Posts
    5,896
    +1
    6
    never mind. lol

  8. #8
    2000 Polaris Pro 1200 rdizz81's Avatar
    Join Date
    May 2010
    Location
    Raleigh, NC
    Posts
    315
    Bowsniper I <3 you

    and lugs here is the link

    http://www.watercraftsuperstore.net/.../607SO053.html


    PA-CD-15/21 Solas Concord Impeller


  9. #9
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31

  10. #10
    2000 Polaris Pro 1200 rdizz81's Avatar
    Join Date
    May 2010
    Location
    Raleigh, NC
    Posts
    315
    Quote Originally Posted by xlint89 View Post

    on this diagram on part #10 how do i get that off the jetpump?

    vice it and bang it? or is there a process to this?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 3
    Last Post: 09-14-2012, 05:08 AM
  2. STX15 Jet pump impeller stuck on driveshaft
    By squared in forum Kawasaki How To & FAQs
    Replies: 1
    Last Post: 09-18-2011, 09:45 PM
  3. Jet pump reassembly questions
    By texas poser in forum Yamaha PWC Performance (4-stroke)
    Replies: 2
    Last Post: 05-28-2011, 02:23 PM
  4. Just took my Carbs off, and I have some questions. Pics included!
    By friscoboater in forum Polaris Open Discussion
    Replies: 9
    Last Post: 07-04-2010, 12:54 PM
  5. Jet pump assembly question
    By cubsfan2516 in forum Polaris Open Discussion
    Replies: 15
    Last Post: 05-13-2009, 03:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •