Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 33

Thread: Pop Off Problem

  1. #1
    CajunSki's Avatar
    Join Date
    Jun 2009
    Location
    Louisiana
    Posts
    24

    Pop Off Problem

    I recently rebuilt a set of carbs for a 800 XLT. I ordered new needles and seats (1.2) for the carbs but the old ones did not look to bad. With the old needle and seat the pop off pressure is right at 81 psi (82 psi is spec for stock carbs). When I install the new needle and seat the pop off is occurring around 60 psi. I repeated the test several times with the same outcome. Any ideas what the problem could be?


  2. #2
    CajunSki's Avatar
    Join Date
    Jun 2009
    Location
    Louisiana
    Posts
    24
    Forgot to mention the springs are 115gram silver.

  3. #3
    CajunSki's Avatar
    Join Date
    Jun 2009
    Location
    Louisiana
    Posts
    24
    Anyone?

  4. #4
    All hail the Chief! fullboogie's Avatar
    Join Date
    Nov 2005
    Location
    Texas
    Posts
    3,155
    +1
    44
    You using WD40 to test the N/S? Did you change springs with the rebuild?

  5. #5
    CajunSki's Avatar
    Join Date
    Jun 2009
    Location
    Louisiana
    Posts
    24
    Yes I used plenty of WD and changed the springs. The new springs are the silver ones that they are using instead of the gold. They are the 115 gram springs. It has me totally confused. With the old N&S and the new springs I can get 80 psi for the pop. With the new N&S it pops around 60 psi every time. Any ideas.

  6. #6
    All hail the Chief! fullboogie's Avatar
    Join Date
    Nov 2005
    Location
    Texas
    Posts
    3,155
    +1
    44
    You answered your own question. You changed springs - that's why the popoff has changed.

  7. #7
    CajunSki's Avatar
    Join Date
    Jun 2009
    Location
    Louisiana
    Posts
    24
    Boogie,

    That's the problem the difference is with the same spring (new one). With the new N&S the popoff is 60 psi and with the old N&S the popoff is 80 psi using the same spring. I really have no idea about why but maybe both new N&S are bad or something.

  8. #8
    All hail the Chief! fullboogie's Avatar
    Join Date
    Nov 2005
    Location
    Texas
    Posts
    3,155
    +1
    44
    You know there are two different silver springs? Sounds like you have the wrong ones and need to order the correct ones. PM Oside Bill for some.

  9. #9

    Join Date
    Sep 2012
    Location
    Central Florida south of lake Okeechobee
    Posts
    29
    I have a question for anyone who may be able to help me. I just bought 2 2002 xlt 800s. One runs perfect so far. The other one not so great. I redid the carbs. Did not change needles or seats. Changed only 1 of the springs. Bc the other carb looked like it was just redone... I redid the carbs because it would not go. When i accelerate it goes for a second and then it doesnt go unless i keep pressing the throttle and letting go and pressing and letting go etc. But still then it wont go over like 15mph. Now if i keep pushing the primer (manually put gas in the carbs is what the primer does) it will go up to 35 or so while i keep priming . if i stop priming then ski slows down. There are no leaks. Ive changed the filter. The filter is filling up as should be.

  10. #10
    mudslanger's Avatar
    Join Date
    Jul 2010
    Location
    Huntsville Al
    Posts
    1,326
    +1
    49
    You can't just half do these carbs even if they look good inside. You should pull them back off and remove the jets under the aluminum block held down by 2 screws next to the spring arm and clean them and blow air threw them and their holes. Also if possible replace both springs on the carbs with the dull silver spring. Try to set the pop off to 45 to 55 psi. Also look close at the 2 small round clear plastic pump disk in each pump block. They can NOT have a crease or rinkle in them. Remove all gaskets and make sure you replace them in the correct order. If you need to contact me you can PM me. Hope this helps.

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. pop-off guage problem / question
    By yama-doo in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 01-04-2014, 07:31 PM
  2. GP1200R carb rebuild: pop-off problems
    By strikeback03 in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 06-23-2013, 08:22 PM
  3. GP760 Carb Problems (POP-OFF Pressure)
    By steelroe in forum Yamaha PWC Performance (2-stroke)
    Replies: 45
    Last Post: 02-21-2013, 09:30 AM
  4. Pop Off Problem
    By ltmark in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 06-01-2012, 11:34 PM
  5. Yamaha Pop-off Presure problems
    By jetman750 in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 10-18-2011, 10:16 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •