Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1
    2000 Polaris Pro 1200 rdizz81's Avatar
    Join Date
    May 2010
    Location
    Raleigh, NC
    Posts
    315

    Ok now im pissed... and done lol

    Well i started to put together my new jetpump and maybe im doing something wrong i dont know..

    how far down is the impeller suppose to tighten and for that matter how do i tighten it do i take off the cone and vice from inside?

    for that matter the impeller if it sits flush with the spacer on the stub shaft than apparently the damn solas impeller is to big there def is no clearance from the walls to the impeller....

    i mean c mon

    any suggestions before i slit my wrist ova here..


  2. #2
    Tony's Avatar
    Join Date
    May 2007
    Location
    North Carolina
    Posts
    1,760
    +1
    38
    Remove the black plastic cone and clamp the end of the stub shaft (under the cone) in a vice and tighten the impeller. Make sure to put the spacer on before the impeller.

  3. #3
    2000 Polaris Pro 1200 rdizz81's Avatar
    Join Date
    May 2010
    Location
    Raleigh, NC
    Posts
    315
    just to be sure the stub shaft should be pulled out as far as it goes right?

    then put on the spacer (grease it first)

    should i fill the cone with grease as well?

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    Quote Originally Posted by rdizz81 View Post
    just to be sure the stub shaft should be pulled out as far as it goes right?

    then put on the spacer (grease it first)

    should i fill the cone with grease as well?
    No grease added to the tail cone (unless you really want to).

    It is good to stuff some grease between the two front seals, then ease the short spacer past the seal lips, then spin the impeller on to the stub shaft.

    The impeller clamps all the pieces together. The rear end of the stub shaft clamps both bearings with the internal spacer between them, and the front spacer against the impeller hub.

  5. #5
    2000 Polaris Pro 1200 rdizz81's Avatar
    Join Date
    May 2010
    Location
    Raleigh, NC
    Posts
    315
    I guess it really doesnt matter because the new impeller i bought

    apparently is the wrong impeller....

    PA-CD-15/21 Solas Concord Impeller

    im guessing i need

    PA-SC-I (15-24) Solas IJK Impeller

    ??

  6. #6

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,702
    +1
    109
    why don't you have them refurbish your original prop it's only 25.00
    and then send that one back and get your money back thats a huge savings

  7. #7
    2000 Polaris Pro 1200 rdizz81's Avatar
    Join Date
    May 2010
    Location
    Raleigh, NC
    Posts
    315
    savings is nice but i dont know of anyone around here that will refurbish the impeller...

    and the shipping both ways will be at least 40

    right?... + look at this thing the shaft is completely frozen in there
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	SDC10623.jpg 
Views:	44 
Size:	134.4 KB 
ID:	189659  

  8. #8

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,702
    +1
    109
    Quote Originally Posted by rdizz81 View Post
    savings is nice but i dont know of anyone around here that will refurbish the impeller...

    and the shipping both ways will be at least 40

    right?... + look at this thing the shaft is completely frozen in there

    The place you bought your prop does it SBT
    40.00 is still 200.00 less
    If you want to throw away 200.00 i have one for you all done and ready to go .As long as you have a core they don't care what it looks like

  9. #9
    2000 Polaris Pro 1200 rdizz81's Avatar
    Join Date
    May 2010
    Location
    Raleigh, NC
    Posts
    315
    Do they send you a refurbished one and take the core ?

    i thought it was you send them yours and wait 2 months and they send it back lol...

    man i am a noob

  10. #10

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,702
    +1
    109
    Quote Originally Posted by rdizz81 View Post
    Do they send you a refurbished one and take the core ?

    i thought it was you send them yours and wait 2 months and they send it back lol...

    man i am a noob
    if it's in stock they send it the same day they get yours if not it takes less then a week

    clamp that old stub shaft in a vice and remove your old prop throw it in a box and ship it out

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. OK now I am confused
    By christian79 in forum Polaris Open Discussion
    Replies: 9
    Last Post: 09-06-2007, 04:07 AM
  2. Intake Grate and ride plate - now im slower!!! HELP!!!
    By jcorallo in forum Yamaha PWC Performance (2-stroke)
    Replies: 26
    Last Post: 07-09-2007, 10:59 PM
  3. Replies: 4
    Last Post: 07-07-2006, 10:14 AM
  4. Relocated PET2500 now getting 9000 RPMs wtf lol
    By NateGP1300R in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 06-17-2006, 07:12 AM
  5. bought a loaded chevy tahoe now im off to the mudbug friday
    By rapidacceleration in forum Sea Doo Open Discussion
    Replies: 14
    Last Post: 06-10-2006, 12:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •