Results 1 to 7 of 7
  1. #1
    olds72's Avatar
    Join Date
    Nov 2009
    Location
    Toledo, OH
    Posts
    173
    +1
    1

    Help, Can't remember where...

    I took my engine out of my 99 GTX RFI kast fall. I bought it with a bad engine. i finally got it back in the hull today. I got most everything hooked back up except this part in the pic. where does it go? I seems like it would be so obvious, but I couldn't locate it;s home. Also have this bolt that I couldn't find a home for. Hopefully I don't have to pull the engine up to put the bolt in it's place. While I'm posting I might as well ask more questions. I took the bottom end to a shop to have the PTO flywheel removed and they removed the mag flywheel as well. They did not mark anything as far as timing goes. The mag flywheel looked pretty straight forward as far as install goes. I lined up the keyway and torques to spces. Should I have line up some timing marks? I have not tried to start it yet, because I'm not to that point. I want to make sure everything is correct.


  2. #2
    mibunkerking's Avatar
    Join Date
    Aug 2008
    Location
    Jax,Fl
    Posts
    2,260
    +1
    117
    i beleive that is supposed to either on the throttle body (as it looks like the TPS but hard to tell in the small pics) or on the airbox manifold that connects to the throttle body.

  3. #3
    olds72's Avatar
    Join Date
    Nov 2009
    Location
    Toledo, OH
    Posts
    173
    +1
    1
    Quote Originally Posted by mibunkerking View Post
    i beleive that is supposed to either on the throttle body (as it looks like the TPS but hard to tell in the small pics) or on the airbox manifold that connects to the throttle body.
    does it go on the mag side or pto side?

  4. #4
    olds72's Avatar
    Join Date
    Nov 2009
    Location
    Toledo, OH
    Posts
    173
    +1
    1
    I did plug in two other wires on the throttle body. One plug had two wires and the other had three. I was left with the remaining plug in the pics.

  5. #5
    RumRunnerRon's Avatar
    Join Date
    Mar 2010
    Location
    Portland, Oregon
    Posts
    462
    Quote Originally Posted by olds72 View Post
    I did plug in two other wires on the throttle body. One plug had two wires and the other had three. I was left with the remaining plug in the pics.

    That is your air pressure sensor. It goes right next to the air temp sensor. Pg. 06-05-13 of the manual shows it.

  6. #6
    olds72's Avatar
    Join Date
    Nov 2009
    Location
    Toledo, OH
    Posts
    173
    +1
    1
    Quote Originally Posted by RumRunnerRon View Post
    That is your air pressure sensor. It goes right next to the air temp sensor. Pg. 06-05-13 of the manual shows it.
    Ahh.. I see it! Thanks. Now to find out where that rather large bolt goes. It's the same color as the engine. I just couldn't locate it's home.

  7. #7
    olds72's Avatar
    Join Date
    Nov 2009
    Location
    Toledo, OH
    Posts
    173
    +1
    1
    GOOD NEWS!! I finished getting the rest of the parts back on (except the large bolt) Hit the start button and she fired right up. I only let it run for a few seconds since I didn't have any water hooked up. Gonna rebuild the jet pump next.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. HELP :: Can't open front hatch
    By EAvila in forum Kawasaki PWC Performance (4-stroke)
    Replies: 3
    Last Post: 08-11-2008, 12:56 PM
  2. Help...can't remove the carbon ring
    By 3dguy in forum Sea Doo Sport Boats
    Replies: 10
    Last Post: 03-24-2008, 04:33 PM
  3. Rude Charger on stock Boat? Can't remember.
    By Water4fire in forum 4-Tec Performance
    Replies: 15
    Last Post: 10-07-2007, 12:21 PM
  4. Need help can't decide on a RXP or RXT
    By andreakobe44 in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 04-15-2007, 07:19 PM
  5. Please Help! Can't remove Large Cotter Pin Karavan Trailer
    By holdnon72 in forum 4-Tec Performance
    Replies: 7
    Last Post: 03-18-2007, 09:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •