Results 1 to 8 of 8
  1. #1

    mfd not working on 96 slx

    my dad(orangeman) bought a 96 slx with the mfd not working. after searching the hulk we figured it was probably the fuse we replaced the fuse but the display still isnt working we pulled it out and there was nothing obviously wrong with it.

    Is there anything else that tends to break on these?


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,591
    +1
    1,275
    Welcome

    Sometimes the MFD just go bad.

    Check that you really do have proper battery voltage at the MFD connector. Black and Red/Purple wires

    Multi-Function Display (MFD)

  3. #3
    thanks we checked in the electrical box and the connection worked do they still sell these?

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,591
    +1
    1,275
    Quote Originally Posted by cptn willigan View Post
    thanks we checked in the electrical box and the connection worked do they still sell these?
    The oval MFD are hard to find. No longer available new from Polaris.

    If you see one for sale, it will tend to go quickly, if it is in good shape.

    Multi-Function Display (MFD)

  5. #5
    theres one on ebay for 85 is that a good price

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,591
    +1
    1,275
    Quote Originally Posted by cptn willigan View Post
    theres one on ebay for 85 is that a good price
    Yes. Often these sell for well over $100, when in good condition.

  7. #7

  8. #8
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Sometimes you just need to "slam" the connector into the back of the MFD. Not sure why, but it won't come on unless you do.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Speedometer Only not working on MFD
    By NYFRANK in forum Polaris Projects
    Replies: 1
    Last Post: 08-28-2014, 07:51 PM
  2. mfd reading fuel low on 96 slx
    By cptn willigan in forum Polaris Open Discussion
    Replies: 2
    Last Post: 06-08-2010, 04:29 PM
  3. 96 SLT 780 MFD not working
    By rc3477 in forum Polaris Open Discussion
    Replies: 14
    Last Post: 06-12-2009, 08:03 PM
  4. mfd not working
    By LANCE in forum Polaris How To & FAQs
    Replies: 6
    Last Post: 05-28-2007, 10:39 PM
  5. Pro cdi and 780 will not work on 94 650..
    By Rodneyae in forum Polaris Open Discussion
    Replies: 25
    Last Post: 05-16-2007, 07:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •