Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1

    Join Date
    May 2009
    Location
    nyc
    Posts
    684
    +1
    7

    putting my brand new 260x in the water tomorrow

    im dropping my ski in tomorrow, so what have you guys found works the best for the motor? i have heard fluid film, or nothing and just wash it with dish soap after. i have already removed the pulley cover and anti siezed the plugs.


  2. #2

  3. #3
    2005 RXT Red08Ultra250's Avatar
    Join Date
    Feb 2008
    Location
    Dunedin, FL
    Posts
    908
    as skip says above, check all the hoses for tightness...

  4. #4
    Offshore Aussie's Avatar
    Join Date
    Jan 2010
    Location
    South East Australia
    Posts
    550
    Lanolin spray in engine bay, but keep it away from the belt area. Remove back seat base and check every hose connection for tightness. Don't go out alone. I have towed ultras before that have blown hoses off the through hull fittings that were brand new! And had been checked by the dealers, oh and myself....Whoops.

  5. #5
    IMVHO I suggest CRC-656. I buy it by the case and coat everything under the seat and the entire pump assembly.

    After riding, I suggest you wash thoroughly each ride with Salt Terminator on a garden sprayer gun set to the "mist" setting as to not force any water into anything, followed by a fresh water rinse then drive home from the harbor with my seats of to aid drying. Also, don't forget to open the drain plugs on the way home..

    A day or so later when everything is dry, I coat the whole engine compartment with 656.

    I have 110 hours, ride 100% salt water and the engine looks new. The 656 keeps corrosion from setting in and everything waterproof..

    Best,
    LB

  6. #6
    Offshore Aussie's Avatar
    Join Date
    Jan 2010
    Location
    South East Australia
    Posts
    550
    Probably have to use 656 myself now I'm back in Artic Australia. Good reply LordBlack. Where I've come from you blink and engine bay is dry!

  7. #7

    Join Date
    May 2009
    Location
    nyc
    Posts
    684
    +1
    7
    Quote Originally Posted by Offshore Aussie View Post
    Lanolin spray in engine bay, but keep it away from the belt area. Remove back seat base and check every hose connection for tightness. Don't go out alone. I have towed ultras before that have blown hoses off the through hull fittings that were brand new! And had been checked by the dealers, oh and myself....Whoops.

    ya i was planning on pulling that off and checking tomorrow, is it just those 4 nuts holding it on?

    got the engine all fluid filmed, battery is charged, stereo is all hooked up, i CANT WAIT!! last year i was riding an 1100 venture lol, i cant wait to get this baby WOT!

  8. #8
    crashhard's Avatar
    Join Date
    Jul 2007
    Location
    Philly PA, Wildwood NJ, Indialantic FL
    Posts
    2,382
    +1
    24
    Should be a good time once broken it. Too bad your too far I am headed out also. Stereo is a clean install, good work.

  9. #9

    Join Date
    May 2009
    Location
    nyc
    Posts
    684
    +1
    7
    yea that stereo is a major PITA to install, but worth it. looks dope with the stickers peeled dont u think?


  10. #10
    crashhard's Avatar
    Join Date
    Jul 2007
    Location
    Philly PA, Wildwood NJ, Indialantic FL
    Posts
    2,382
    +1
    24
    yea its sick, you definitely did the radio the right way though. The 260 to the raider is one hell of an upgrade. Let me know who it goes tomorrow.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New to the family but put my Ultra 300 LX in the water yesterday, what a ride....
    By Fiftydriver in forum Kawasaki PWC Performance (4-stroke)
    Replies: 12
    Last Post: 05-17-2012, 10:26 PM
  2. When do you put your ski's back in the water? Poll
    By rickreeves1 in forum Polaris Open Discussion
    Replies: 9
    Last Post: 04-10-2008, 12:40 PM
  3. Any Reason Not To Leave My Boat In The Water
    By manchild27 in forum Sea Doo Sport Boats
    Replies: 2
    Last Post: 09-13-2007, 12:21 AM
  4. problem starting my skii in the water
    By andy95'slx780 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 05-15-2007, 03:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •