Results 1 to 9 of 9
  1. #1

    Join Date
    May 2010
    Location
    Salem, Ohio
    Posts
    51

    SC Reinstallation

    I pulled my SC off last night to see if it had the metal washers, it did. My question is about reinstallation. Is there anything I need to do other then apply an anti-seize grease between the block and SC housing and lock-tite the bolts? do i have to torque the bolts to a specific lb/ft?


  2. #2
    jdbretz's Avatar
    Join Date
    Jul 2009
    Location
    Raeford, NC
    Posts
    260
    I can't recall the exact torque, but I do snug, then a quarter turn and haven't had any issues. You don't need to torque it down as hard as you can. Use blue loctite on the bolts.

  3. #3

    Join Date
    May 2010
    Location
    Salem, Ohio
    Posts
    51
    What is the difference between blue and red? I have both

  4. #4
    jdbretz's Avatar
    Join Date
    Jul 2009
    Location
    Raeford, NC
    Posts
    260
    Red as a much higher break point. If you install it with Red Loctite, you may have A LOT of trouble getting it back out and may break the screw in the process. Blue is what the service manual recommends and what everyone else uses, if they even use it at all.

  5. #5

    Join Date
    May 2010
    Location
    Salem, Ohio
    Posts
    51
    Thanks Jd! Blue it is. As for the anti-seize, any particular brand? Work the stuff from autozone work?

  6. #6
    jekvall's Avatar
    Join Date
    Nov 2007
    Location
    Chillicothe, OH
    Posts
    353
    AutoZone stuff is fine.
    Be sure to tighten all of the hose clamps!

  7. #7
    jdbretz's Avatar
    Join Date
    Jul 2009
    Location
    Raeford, NC
    Posts
    260
    Quote Originally Posted by jekvall View Post
    AutoZone stuff is fine.
    Be sure to tighten all of the hose clamps!
    +1 I use the AutoZone anti-sieze stuff

  8. #8
    Big K's son KeithKman's Avatar
    Join Date
    Dec 2006
    Location
    Southern California
    Posts
    1,735
    Does the anti-seize just go between the base of the SC where it butts up to the block?

  9. #9
    I coat the o-rings to the base.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. SC Reinstall 04-07
    By oct6454 in forum 4-Tec Performance
    Replies: 17
    Last Post: 10-23-2011, 10:24 PM
  2. Any SC reinstall tips for an 04 RXP?
    By robby212 in forum 4-Tec Performance
    Replies: 6
    Last Post: 04-29-2010, 08:44 PM
  3. SC reinstall question
    By cactusrider in forum 4-Tec Performance
    Replies: 19
    Last Post: 01-30-2008, 03:01 AM
  4. reinstall of SC
    By calvinhead in forum 4-Tec Performance
    Replies: 4
    Last Post: 07-17-2007, 09:24 PM
  5. RXP - Reinstalled SC
    By Jimbo in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-12-2007, 09:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •