Results 1 to 9 of 9
  1. #1

    Join Date
    Jul 2005
    Location
    Las Vegas, NV
    Posts
    101

    RR impellar and # 42 injectors

    After a bad blowup, I put my new engine together with the RR sc impellar and RR cam on an unported head (lightweight retainers etc. installed). We fired the new engine with the #42 injectors and it ran rich enough to foul a set of IXU27's in less than 5 minutes on the trailer. The 42's have a purple ring on the base with no ID for size. We put the #38 stockers back in and launched the boat for a test, although gently because it's a new motor. Even after a burst, they seem a little rich but OK. Temp was 75 air, dry, and 75 water also. Has anybody else had this happen? Is there a color code to the injectors as Jerry's website has them look brown in the picture? Help! I can't afford another $7,000.


  2. #2
    Moderator Franko's Avatar
    Join Date
    Apr 2005
    Location
    Dallas, Texas
    Posts
    3,829
    +1
    2
    Hmmmm. My experience has been that the 42 lbs injectors tend to run pretty rich. I have wondered whether it is really necessary to run them. But I go with what the experts say. Is your ski hard to start?

  3. #3
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    terry, if your ski still seems rich with the 38's then there is a problem.

    Did you hit set 5 times to look for a trouble code?

    I have seen the 42# injectors come with both brown and purple bands on them.

  4. #4

    Join Date
    Jul 2005
    Location
    Las Vegas, NV
    Posts
    101
    Thanks for the replies. There are no fault codes, even checked on BUDS. With the 38's, the machine starts and runs perfectly, but the plug check shows a little richer than when I was running the ported head. I assumed the ski would have shown a touch lean because of the RR sc imp and what I've read and heard, especially with temp and water at 75 compared to running at 100 plus with 80 degree water as I had when it broke.

  5. #5
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Interesting! How does it run?

  6. #6

    Join Date
    Jul 2005
    Location
    Las Vegas, NV
    Posts
    101
    Jerry, With the new engine and white cap water (wind), I was taking it easy, running about 35 to 40 mph. I gave it only one 2 second blast only, and it jumped instantly to about 8100 rpm. I shut it down and glanced at gps reading 65, which says really nothing because it was only that second or so, but it accelerated like a raped ape in the moonlight. (Interesting graphic, huh?)

  7. #7
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Quote Originally Posted by terryt
    but it accelerated like a raped ape in the moonlight. (Interesting graphic, huh?)
    I like that Terry

  8. #8
    Gotta love this sport! 05Limited's Avatar
    Join Date
    Apr 2005
    Location
    Stockton, CA
    Posts
    2,677
    +1
    4
    Quote Originally Posted by terryt
    ... but it accelerated like a raped ape in the moonlight...
    Only proper time to rape an ape, IMHO

  9. #9
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,059
    +1
    790
    I think in the 100 degree texas heat I am gonna use the stock 38's, but from now until next year put the 42's in.
    This might push me to install a A/F gauge.

    .

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RR ECU and 42# and springs for sell
    By bartmen in forum 4-Tec Performance
    Replies: 0
    Last Post: 06-15-2010, 01:31 PM
  2. Replies: 1
    Last Post: 08-22-2009, 12:47 AM
  3. F/S OEM RXP-X supercharger and 42# injectors
    By BIGWORM in forum Sea Doo Classifieds
    Replies: 22
    Last Post: 06-22-2009, 10:05 AM
  4. RR ECU and 42s runs rich?
    By Vern in forum 4-Tec Performance
    Replies: 4
    Last Post: 07-16-2008, 08:31 PM
  5. Surging at idle w/ RR whell and 42's? Normal?
    By Water4fire in forum 4-Tec Performance
    Replies: 25
    Last Post: 04-10-2007, 07:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •