Results 1 to 9 of 9

Thread: Need Help K447

  1. #1

    Need Help K447

    Installed update kit 2873355 was checking to make sure ground wires wasnt shorted to other wires in harness battery wasnt in ski ground wire unpluged but forgot to unplug other wires at board touched ohms meter to ground and 1 of the wires heard pop sound like may have been from cdi put ski together no fire! Do you think I blew the cdi? Thanks Keith


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,597
    +1
    1,276
    Quote Originally Posted by KHVETTE View Post
    Installed update kit 2873355 was checking to make sure ground wires wasn't shorted to other wires in harness

    battery wasn't in ski
    ground wire unplugged but forgot to unplug other wires at board

    touched ohms meter to ground and 1 of the wires heard pop sound like may have been from cdi

    put ski together no fire!
    Do you think I blew the cdi? Thanks Keith
    What type of meter were you using?

    A normal multi-meter does not have the voltage to damage anything.

    If the battery was disconnected, then there is no source of power to damage anything with.

    Did the electrical box TOUCH the battery post?

  3. #3
    Using a fluke Battery wasnt in ski

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,597
    +1
    1,276
    Quote Originally Posted by KHVETTE View Post
    Using a fluke

    Battery wasn't in ski
    Well then, I don't see how you could have electrically damaged anything.

  5. #5
    Gray wire coming back from stator flat plug (updated ign 96 700 slt) where should it hook? shooting in the dark Thanks Keith

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,597
    +1
    1,276
    Quote Originally Posted by KHVETTE View Post
    Gray wire coming back from stator flat plug (updated ign 96 700 slt)

    where should it hook?
    ...
    It should connect to the Gray wire on the CDI with the matching connector.

    There are TWO gray wires on the CDI.

    One gray CDI wire connects directly to the magneto stator, and is part of the Hall Effect sensor circuit.

    The other gray CDI wire is for the RPM limiter, and connects to the Gray (or Tan on some models) connection on the terminal board.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Polaris PVL Update Kits2_001.jpg 
Views:	46 
Size:	44.4 KB 
ID:	190367  

  7. #7
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Quote Originally Posted by KHVETTE View Post
    Installed update kit 2873355
    Quote Originally Posted by KHVETTE View Post
    Gray wire coming back from stator flat plug (updated ign 96 700 slt) where should it hook? shooting in the dark
    Every kit I've installed has a set of directions, do they no longer include them?

  8. #8
    Yes they still have them. Only says grey wire goes to rev limiter not used on all models.Diagram doesnt show it going anywhere.Elect. 38 yrs experence,not a jetski mechanic.No one around here will work on polaris! Not even our polaris dealer.Thanks for your help.

  9. #9
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,597
    +1
    1,276
    Quote Originally Posted by KHVETTE View Post
    Yes they still have them. Only says grey wire goes to rev limiter not used on all models.

    Diagram doesn't show it going anywhere.E

    lect. 38 yrs experience,not a jetski mechanic.

    No one around here will work on Polaris! Not even our Polaris dealer.

    Thanks for your help.
    Do you have the info you need now?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. K447 I need help
    By KHVETTE in forum Polaris Open Discussion
    Replies: 0
    Last Post: 05-25-2010, 03:18 PM
  2. K447 I need help
    By KHVETTE in forum Polaris Open Discussion
    Replies: 0
    Last Post: 05-25-2010, 03:07 PM
  3. NEED HELP URGENT(HULK) RXP DOWN
    By macattack in forum 4-Tec Performance
    Replies: 28
    Last Post: 11-22-2005, 02:39 PM
  4. I need help remove stock intercooler
    By orc in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-13-2005, 04:08 PM
  5. NEED HELP!!!!!
    By MartyRXP in forum 4-Tec Performance
    Replies: 11
    Last Post: 05-10-2005, 08:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •