Results 1 to 2 of 2

Thread: pump problems

  1. #1

    Join Date
    Apr 2010
    Location
    cross,sc
    Posts
    22

    pump problems

    im just trying to figure out what kind of pump is in my 97 stx 1100, since its not the original one that it came with in 97. i ordered a new solas impeller to fit my stx and when i got it today it is to big and wont fit into the housing on this pump. about a quarter inch to big all the way around. anyone now what pumps can bolt up to my stx also. if im guessing right i have a 145 mm pump housing and a new 148mm impeller. just wont work. and im trying to get it ready to ride this long weekend


  2. #2

    Join Date
    Apr 2010
    Location
    cross,sc
    Posts
    22
    i decided to send my pump and impeller to impros to get reworked and done right. it wasnt chewed up to bad so i can save it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Jet Pump problem??? I need direction
    By xxpertsonly in forum Polaris Open Discussion
    Replies: 31
    Last Post: 10-14-2007, 09:59 PM
  2. pump problems!!!
    By FL03GTX in forum 4-Tec Performance
    Replies: 2
    Last Post: 09-09-2007, 07:45 AM
  3. 2003 GTX 4 TEC/SC pump problems
    By HD RACING in forum 4-Tec Performance
    Replies: 3
    Last Post: 09-02-2007, 06:49 PM
  4. SLTX 97 Polaris,jet pump problem
    By grifter in forum Polaris How To & FAQs
    Replies: 10
    Last Post: 05-24-2007, 03:09 PM
  5. Pump Problem
    By njgprider in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 08-11-2006, 08:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •