Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 33
  1. #1

    95 slt 750 fuel problem

    I got a 95 polaris slt 750 and rebuilt the whole top end put the triple out flow fuel pump on it and blocked off the oil and went to premix. I can get it to start and idle but when I give it gas all it does is fall on it face and dies out! Is there something that i am missing or something else I need to do?????


  2. #2
    MicahN's Avatar
    Join Date
    May 2010
    Location
    Kansas
    Posts
    93
    Quote Originally Posted by johnny7 View Post
    I got a 95 polaris slt 750 and rebuilt the whole top end put the triple out flow fuel pump on it and blocked off the oil and went to premix. I can get it to start and idle but when I give it gas all it does is fall on it face and dies out! Is there something that i am missing or something else I need to do?????
    Try opening the high end screws on your carbs 1/8th. What fuel/oil ratio are you using?

  3. #3
    ok just opend 1/8 and still the same thing and with the pistons being brand new i was told to use 35 to 1 for the break in

  4. #4
    MicahN's Avatar
    Join Date
    May 2010
    Location
    Kansas
    Posts
    93
    You could try to go up to 1/4th from original setting, but if going 1/8 didn't improve it it's probably not going to help. Are you still using the autocock and water seperator?

  5. #5
    MicahN's Avatar
    Join Date
    May 2010
    Location
    Kansas
    Posts
    93
    Quote Originally Posted by johnny7 View Post
    i was told to use 35 to 1 for the break in
    35:1 should work fine. A lot of people go all the way to 40:1 for break in.

  6. #6
    yeah still useing the autocock and waterseperator should I bypass it and go right to the fuel pump?

  7. #7
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Quote Originally Posted by MicahN View Post
    35:1 should work fine.

    A lot of people go all the way to 40:1 for break in.
    That is the wrong way around

    40:1 is the normal pre-mix ratio AFTER break-in

    For engine break-in, the norm is 32:1

  8. #8
    MicahN's Avatar
    Join Date
    May 2010
    Location
    Kansas
    Posts
    93
    Quote Originally Posted by K447 View Post
    That is the wrong way around

    40:1 is the normal pre-mix ratio AFTER break-in

    For engine break-in, the norm is 32:1
    I stand corrected! A lot of people are wrong, haha.

    Good thing I used the 32:1 for mine.

  9. #9
    MicahN's Avatar
    Join Date
    May 2010
    Location
    Kansas
    Posts
    93
    Quote Originally Posted by johnny7 View Post
    yeah still useing the autocock and waterseperator should I bypass it and go right to the fuel pump?
    I would do away with the autocock first and see if that helps.

  10. #10
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Quote Originally Posted by johnny7 View Post
    yeah still using the autocock and water seperator

    should I bypass it and go right to the fuel pump?
    Delete the auto-cock right away!
    Cap off the auto-cock connection at the engine intake.

    Make sure the fuel/water separator is clean and seals well. It must not allow air leaks into the fuel system. The fuel pump creates suction between the fuel tank and the fuel pump.

    Make sure the fuel selector valve is in good shape. Clean it internally, and replace the o-ring if you can. Lightly grease the seal, and re-assemble.

    Do not delete or bypass the fuel selector valve. It is important that you be able to shut off the fuel when you are not using the engine.

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1995 polaris slt 750 fuel problem
    By fryestyle16 in forum Polaris PWC Performance
    Replies: 1
    Last Post: 07-20-2013, 10:34 AM
  2. 95 slt 750 fuel tank sending unit
    By wacomcleod in forum Polaris Open Discussion
    Replies: 1
    Last Post: 05-05-2012, 10:00 PM
  3. 94 slt 750 fuel problem. Help!
    By MicahN in forum Polaris Open Discussion
    Replies: 19
    Last Post: 06-02-2011, 10:59 PM
  4. 95 SLT 750 Fuel in pulse line
    By buffalomoz in forum Polaris How To & FAQs
    Replies: 12
    Last Post: 10-27-2010, 09:22 PM
  5. fuel primer for 95' slt 750
    By xplayer2885 in forum Polaris How To & FAQs
    Replies: 7
    Last Post: 08-03-2008, 09:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •