Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1
    Waiting for summer! Gmanpaint's Avatar
    Join Date
    Dec 2009
    Location
    SW MO
    Posts
    12

    96 1100cc waveraider...oil mix too rich?

    Can anyone tell if this is running too rich and what I have to do to lean it out if it is? This thing smokes like crazy to me. It has always ran Yamalube only, and has 137 hrs on a new engine.



  2. #2
    I would look at the spark plugs to see if it's running rich. The service manual will guide you through troubleshooting this. You should consider switching to pre-mix if you haven't.

  3. #3
    Waiting for summer! Gmanpaint's Avatar
    Join Date
    Dec 2009
    Location
    SW MO
    Posts
    12
    I pulled the plugs, looked ok. They are new though.

    Guess I can search for a how to on the mod to eliminate the oil injector.

    I just don't think that it should smoke so bad. I was thinking the worse, like bad rings, but the compression is still ok in all 3. Im no expert thats for sure. I am kinda embarrassed about the fact I can ride like crazy, but can't wrench on em too much...lol

    This why I joined, to learn. Have to start somewhere

  4. #4

    Join Date
    May 2010
    Location
    Bettendorf, Iowa
    Posts
    81

    Smokin'

    My 1100 smoked like that too. Especially at idle. It was like a WW2 destroyer laying down cover for merchant shipping.

    Last season I added flame arrestors, which are basically 3 small aftermarket air cleaners. I also removed the choke and replaced it with a primer kit. These changes required me to adjust my carb mixtures and afterwards I had less smoke.

  5. #5
    Mpeavler's Avatar
    Join Date
    Dec 2005
    Location
    Anderson, Indiana
    Posts
    5,155
    +1
    170
    Yeah raider pump is not variable...so you get the same oil at idle as WOT.....50:1 it will smoke a ton at idle

    M

  6. #6
    Waiting for summer! Gmanpaint's Avatar
    Join Date
    Dec 2009
    Location
    SW MO
    Posts
    12
    Quote Originally Posted by Mpeavler View Post
    Yeah raider pump is not variable...so you get the same oil at idle as WOT.....50:1 it will smoke a ton at idle

    M
    That makes so much sense to me. This has to be why I go thru a set of plugs fast.

    So removing (or bypassing) the injector and running premix at what ratio. 36:1 ?

  7. #7
    Mpeavler's Avatar
    Join Date
    Dec 2005
    Location
    Anderson, Indiana
    Posts
    5,155
    +1
    170
    Stock ....50:1 is fine....any performance mods...40:1 or 32:1 depending on power output

    M

  8. #8
    Waiting for summer! Gmanpaint's Avatar
    Join Date
    Dec 2009
    Location
    SW MO
    Posts
    12
    Thank you

  9. #9

    Join Date
    May 2009
    Location
    nyc
    Posts
    684
    +1
    7
    my venture 1100 and raider 1100 both smoke like whores. its the oil injection its normal.

  10. #10
    cheatin' piston popper addicted's Avatar
    Join Date
    Jul 2006
    Location
    north jersey
    Posts
    6,188
    +1
    176
    they all smoke like that. injector is fixed ratio, so unless you run some synthetic, pre mixing will make no difference in the smoke. try some amsoil hp injector or interceptor. it will smoke less than 1/2 of what you get with regular oil.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. oil mix ratio waveraider 1100?
    By burton9010 in forum Yamaha Old School Skis
    Replies: 1
    Last Post: 08-04-2009, 06:16 AM
  2. 1995 Waveraider 1100 getting too much oil/Mechanic suggestions?
    By jasond32 in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 07-06-2009, 09:34 PM
  3. Too rich for my blood but someone may need this
    By TX21 in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 12-28-2007, 10:55 AM
  4. gtx 96 seadoo 650cc oil pump question
    By andy95'slx780 in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 08-19-2007, 08:59 PM
  5. Oil mix
    By Blackhardt in forum 4-Tec Performance
    Replies: 3
    Last Post: 10-12-2006, 07:55 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •