Results 1 to 3 of 3
  1. #1

    Exclamation 155 4tec running rough????

    I recently bought this used motor from ebay, its in the ski now and I have been trying to get it too run smooth. It idles up and down, then it will stick at around 3000 and stay at that rpm till I shut it down. Also when I hit the throttle it bogs down and takes a bit to catch up. I have not had it in the water yet, just still trying to get it to run good. Oil has been changed along with new fuel. I do not know much about this engine nor did the owner.

  2. #2
    rangermtb5's Avatar
    Join Date
    Apr 2008
    North Jersey
    start with new spark plugs

  3. #3
    Replaced the plugs and still cant get it to run smooth

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 07 160 HO rough running/missing
    By Orrible in forum Yamaha PWC Performance (4-stroke)
    Replies: 2
    Last Post: 03-17-2008, 06:12 PM
  2. 2001 gtx rough running any ideas?
    By baba850r in forum 2-Stroke Performance
    Replies: 5
    Last Post: 02-18-2008, 11:21 AM
  3. VX 110 Rough running
    By Bernie in forum Yamaha Open Discussion
    Replies: 2
    Last Post: 12-21-2007, 09:25 AM
  4. Which to buy. 155 HP GTX or 155 GTI SE
    By zone 5 in forum Sea Doo Open Discussion
    Replies: 13
    Last Post: 08-08-2007, 08:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts