Results 1 to 3 of 3
  1. #1

    Exclamation 155 4tec running rough????

    I recently bought this used motor from ebay, its in the ski now and I have been trying to get it too run smooth. It idles up and down, then it will stick at around 3000 and stay at that rpm till I shut it down. Also when I hit the throttle it bogs down and takes a bit to catch up. I have not had it in the water yet, just still trying to get it to run good. Oil has been changed along with new fuel. I do not know much about this engine nor did the owner.


  2. #2
    rangermtb5's Avatar
    Join Date
    Apr 2008
    Location
    North Jersey
    Posts
    4,473
    +1
    58
    start with new spark plugs

  3. #3
    Replaced the plugs and still cant get it to run smooth

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Running rough 2014 gti 155 limited
    By kevin96xx in forum 4-Tec Performance
    Replies: 9
    Last Post: 10-28-2015, 11:40 AM
  2. 2011 GTX 155 runs rough...
    By mirage2991 in forum 4-Tec Performance
    Replies: 0
    Last Post: 08-25-2012, 05:16 PM
  3. RXP-X Running Rough
    By MPower in forum 4-Tec Performance
    Replies: 9
    Last Post: 05-26-2008, 11:57 PM
  4. 05 rxt runs rough
    By newskiier in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-09-2008, 08:54 PM
  5. Ultra 250 runs rough until hot with 27hrs
    By DIABLO ROJO in forum Kawasaki PWC Performance (4-stroke)
    Replies: 27
    Last Post: 08-06-2007, 10:46 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •