Results 1 to 10 of 10
  1. #1
    Cashito's Avatar
    Join Date
    Feb 2010
    Location
    Delray Beach
    Posts
    198
    +1
    4

    Corrosin On Engine After Riding (Pics inside)

    What could this be? I tried to ride without the seat to see if it was leaking from somewhere but found nothing.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_0669.jpg 
Views:	97 
Size:	120.2 KB 
ID:	190543  


  2. #2
    Sea-Yaa's Avatar
    Join Date
    Jul 2007
    Location
    Clearwater, Fl
    Posts
    290
    +1
    7
    To me it looks like salt build up, some kind of calcium deposits....can u rub it off? Are you using any kind of silicone spray or anything before you go riding?

  3. #3
    RXP305's Avatar
    Join Date
    Jun 2009
    Location
    Miami
    Posts
    311
    Quote Originally Posted by Cashito View Post
    What could this be? I tried to ride without the seat to see if it was leaking from somewhere but found nothing.
    Lift the valve head plastic cover and look to see if is comming from the inside.

  4. #4
    Orlando Shark's Avatar
    Join Date
    Mar 2009
    Location
    Miami, FL
    Posts
    2,419
    +1
    10
    My friend's X is looking the same way....It's white looking which looks like salt deposit and comes off with XPS or any corrosion inhibitor but he just took it to the dealer and they told him that he has a warped head...They also told him that they will try to see if seadoo covers it because he has an aftermarket intake which might void the warranty.....

  5. #5
    jekvall's Avatar
    Join Date
    Nov 2007
    Location
    Chillicothe, OH
    Posts
    353
    check the J-PIPE for a hairline crack, I had one do that and it would shoot a stream of water as thin as a human hair up there and looked just like that.

    check it running on a hose.

  6. #6
    Cashito's Avatar
    Join Date
    Feb 2010
    Location
    Delray Beach
    Posts
    198
    +1
    4
    Ya, it comes off everytime with a hose or XPS. The weird part is it happens after riding in the lake too. I'm confused, will have to investigate more.

  7. #7
    Orlando Shark's Avatar
    Join Date
    Mar 2009
    Location
    Miami, FL
    Posts
    2,419
    +1
    10
    Quote Originally Posted by Cashito View Post
    Ya, it comes off everytime with a hose or XPS. The weird part is it happens after riding in the lake too. I'm confused, will have to investigate more.
    If you still have warranty I'd take it to the dealer and have them take a look at it...Make sure you have an intake filter on the Kanaflex before you do because if it's a problem they will not want to warranty it.

  8. #8
    Cashito's Avatar
    Join Date
    Feb 2010
    Location
    Delray Beach
    Posts
    198
    +1
    4
    No warranty.... gonna have to figure it out on my own

  9. #9
    Bajacali's Avatar
    Join Date
    Feb 2008
    Location
    Sarasota,FL.
    Posts
    49
    It does look like salt. I've had this happen to mine. After thoroughly cleaning the engine compartment I usually spray the entire area with the Seadoo XPS spray oil. Expensive I know but, if you can't pay, don't play. Look at the easy stuff first. Tears in the seat or saltwater coming from that area. Don't be afraid to use a pressure washer in the engine compartment.

  10. #10
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    Quote Originally Posted by jekvall View Post
    check the J-PIPE for a hairline crack, I had one do that and it would shoot a stream of water as thin as a human hair up there and looked just like that.

    check it running on a hose.
    Its an O8 X No J-PIPE...

    Looks like salt to me bro. Prob no biggie but you need to keep that thing really clean riding in that salt!!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Salt water on engine after riding. RXPX300
    By rxp_boy in forum 4-Tec Performance
    Replies: 19
    Last Post: 08-23-2016, 04:23 AM
  2. Cleaning inside the engine when riding on salt water?
    By justjmfh in forum Kawasaki PWC Performance (2-stroke)
    Replies: 4
    Last Post: 11-23-2012, 09:09 AM
  3. Need Info on these ECU please :) pics inside.
    By otoss in forum 4-Tec Performance
    Replies: 4
    Last Post: 10-15-2012, 01:43 PM
  4. Friggin Powervalve Failure!! Need some input on extent of damage (pics inside)
    By chicagoanalog in forum Yamaha PWC Performance (2-stroke)
    Replies: 12
    Last Post: 07-07-2012, 10:40 AM
  5. First test ride results on RXP after new mods...
    By JAG in forum 4-Tec Performance
    Replies: 44
    Last Post: 12-24-2006, 08:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •