Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1

    Join Date
    Aug 2008
    Location
    Rosemont,IL
    Posts
    23

    oil light comes on and engine stumbles

    I have a 04 rxp that just got a riva stage 3 put on it (light weight valves also) , i just started it for the first time after about a minute the oil light came on and the engine started to stumble. I also notice that when this happened it had more vacume than normal at idle. So far i have checked the oil level it is just below the top bend not sure what else i should check. Thanks for any advice


  2. #2
    Richieb's Avatar
    Join Date
    Oct 2008
    Location
    Sydney, Australia.
    Posts
    1,001
    OPS disease.

    The oil pressure switch under the manifold is your man.

    No real solution, just replace it.

  3. #3

    Join Date
    Aug 2008
    Location
    Rosemont,IL
    Posts
    23
    ok thanks, why is it making the engine stumble?

  4. #4
    Richieb's Avatar
    Join Date
    Oct 2008
    Location
    Sydney, Australia.
    Posts
    1,001
    The Engine goes in to "Limp Mode", which reduces the engine RPM to protect it, but get you to safety ...all being well.

    It feels like a massive mis-fire is a way to describe it.

    You can lightly use the throttle to get you moving, but it will not allow any real kind of performance from it.

    Sometimes, by stopping the engine, and re-starting it, the Oil Pressure Switch may get itself together if it is squiffy, and allow you ride on, and by experience, once this happens, and the engine is not cooled right down, it will perform normally all day long..... until next time you ride, and it will exhibit the same symptoms again.

    You may be able to tollerate this. I had one of my skis with this problem. I would leave the ramp, bimble to the open speed area, open the throttle, hold on..... and it would go to limp mode, alarm and red light on the dash. I would start and stop the ski... sometimes up to six times, but eventually, it got over its OPS alarm, and run flawlessly for the rest of the day... unless the engine was stopped, and allowed to cool right down. In which case, the same solution, i.e. start/stop/start/stop/start....

    The OPS(Oil pressure switch) will need to be changed to fix this in the end.

    Some say there was a bad batch of them at one time. I have seen one ski go to 5 before it was ok, yet I changed mine, and that was it... all good.

    Hope this helps.

    By clicking this link, you will see item #30 is the one you should replace.

    Linky-> http://partsfinder.onlinemicrofiche....e=13&A=118&B=4
    Last edited by Richieb; 05-27-2010 at 09:01 PM. Reason: More info

  5. #5
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    You might bump part number so all will know whitch switch your refering too. :

  6. #6
    Richieb's Avatar
    Join Date
    Oct 2008
    Location
    Sydney, Australia.
    Posts
    1,001
    Ok, good point. Have edited post to suit.


  7. #7

    Join Date
    Aug 2008
    Location
    Rosemont,IL
    Posts
    23
    thanks for all the help, ordered the part and hopefully can go out next weekend.

  8. #8

    Join Date
    Aug 2008
    Location
    Rosemont,IL
    Posts
    23
    ok i replaced the pressure sensor and the oil light stopped coming on. I took it out to test it and as the rpms incresed the vacume on my guage went from 10 to 20. I only went up to 6000 rpms and it was still at 20. Its a stage 3 rxp with an brand new x-charger. Is this normal?

  9. #9
    Richieb's Avatar
    Join Date
    Oct 2008
    Location
    Sydney, Australia.
    Posts
    1,001
    What is the gauge for, and where is it?

  10. #10

    Join Date
    Aug 2008
    Location
    Rosemont,IL
    Posts
    23
    sorry its the boost/ vacume gauge

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 8
    Last Post: 05-08-2016, 01:50 PM
  2. When exactly will the low oil light come on and go off?
    By MrBrainerd in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 07-17-2013, 09:39 PM
  3. Unlock light coming on and wierd beeeeeep sound!!help
    By fxho in forum Yamaha PWC Performance (4-stroke)
    Replies: 1
    Last Post: 09-23-2009, 09:15 PM
  4. Oil light comes on
    By super_gtx in forum 4-Tec Performance
    Replies: 18
    Last Post: 08-17-2008, 06:29 PM
  5. 2003 GTX SC oil light comes on but oil level is fine??
    By djbauer in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 07-25-2006, 04:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •