Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267

    Unhappy My new custom 15/22r

    Check this out


  2. #2
    Never say never KirkF350's Avatar
    Join Date
    Jun 2005
    Location
    Midlothian, Texas
    Posts
    4,433
    +1
    3
    Dude! What the hell did you hit?

  3. #3
    Project_X's Avatar
    Join Date
    Dec 2009
    Location
    Miami
    Posts
    162
    He ran over a yamalog. lol

  4. #4
    ADAMBOMB's Avatar
    Join Date
    Mar 2006
    Location
    Sunrise,Florida
    Posts
    4,723
    +1
    196
    talking about a late night snack!!! Wow.

  5. #5
    Banned User
    Join Date
    Aug 2009
    Location
    Discovery Bay, CA
    Posts
    3,048
    +1
    336
    daaaaaang sorry about that dude!! we got to know what it was, rock?

  6. #6
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Was just cruising around 65mph. The ski felt like I sucked up a some grass or something, then fine. About another couple minutes I started to get a bad vibration like something was really sucked up in the pump. Shut the ski down, did all the normal stuff trying to clear it out and nothing. So I puled over near a sand bar and tried to see if something was stuck in the grate, nothing. Tried to start it and it would not turn over. After about 15 min it started and I limped (it stil ran 62) to a nearby marina. Thanks to KirkF350 for a assist on helping me get my truck and trailer.

  7. #7
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Looking at the prop I am thinking this has to have been an ongoing thing. I mean for those blades to all be bent, couldnt just happened all at once? This was on my RXPX that has all the normal stg1 mods, plus a few extra. The ski ran 77.3 @ 8040 about 2 weeks ago.

  8. #8
    formerly Gold06RXP Turbo Nick's Avatar
    Join Date
    May 2007
    Location
    Dayton, OH
    Posts
    2,095
    +1
    97
    Has it been pitched at all?

  9. #9
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Quote Originally Posted by GOLD06RXP View Post
    Has it been pitched at all?
    Yep, not by me though.

  10. #10
    formerly Gold06RXP Turbo Nick's Avatar
    Join Date
    May 2007
    Location
    Dayton, OH
    Posts
    2,095
    +1
    97
    I have a prop that has been pitched up and down multilple times and cracked at the trailing edge on two blades. However Mine cracked while being pitched so it was never run. I was able to TIG weld it and sand the welds smooth and it was fine. Its to late for yours though

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. My new custom carbs
    By thrasher63 in forum Yamaha Open Discussion
    Replies: 3
    Last Post: 07-08-2011, 12:09 AM
  2. F/S New Riva 15/22R Solas 4/Blade
    By FAST RXP in forum Sea Doo Classifieds
    Replies: 6
    Last Post: 05-31-2010, 07:46 AM
  3. FS: New Solas 15/22r X impeller
    By vxrpete8 in forum Sea Doo Classifieds
    Replies: 11
    Last Post: 11-15-2008, 05:38 PM
  4. New Solas 15/22R impellers coming soon
    By Green Hulk in forum 4-Tec Performance
    Replies: 61
    Last Post: 05-14-2008, 12:47 PM
  5. My New Custom Exhaust...
    By GeoRXT in forum 4-Tec Performance
    Replies: 8
    Last Post: 07-24-2006, 11:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •